Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Labels:
      None
    • Environment:
      Linux, Hudson v1.386, Warnings plugin v3.11

      Description

      Builds are finishing with a failure result, and the following exception is being shown:

      [WARNINGS] Parsing warnings in console log...
      ERROR: Publisher hudson.plugins.warnings.WarningsPublisher aborted due to exception
      java.lang.NullPointerException: Name is null
      at java.lang.Enum.valueOf(Enum.java:195)
      at hudson.plugins.analysis.util.model.Priority.valueOf(Priority.java:18)
      at hudson.plugins.analysis.core.HealthAwarePublisher.getMinimumPriority(HealthAwarePublisher.java:522)
      at hudson.plugins.analysis.core.AbstractHealthDescriptor.<init>(AbstractHealthDescriptor.java:36)
      at hudson.plugins.warnings.WarningsHealthDescriptor.<init>(WarningsHealthDescriptor.java:25)
      at hudson.plugins.warnings.WarningsResultAction.<init>(WarningsResultAction.java:31)
      at hudson.plugins.warnings.WarningsPublisher.perform(WarningsPublisher.java:202)
      at hudson.plugins.analysis.core.HealthAwarePublisher.perform(HealthAwarePublisher.java:280)
      at hudson.tasks.BuildStepMonitor$2.perform(BuildStepMonitor.java:27)
      at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:603)
      at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:582)
      at hudson.maven.MavenModuleSetBuild$RunnerImpl.post2(MavenModuleSetBuild.java:651)
      at hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:529)
      at hudson.model.Run.run(Run.java:1349)
      at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:349)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:139)

      If I disable the warnings publisher from the job configuration, the build ends successfully.

      Here is the config section of the warnings plugin of the job:

      <hudson.plugins.warnings.WarningsPublisher>
      <pluginName>[WARNINGS] </pluginName>
      <defaultEncoding></defaultEncoding>
      <canRunOnFailed>false</canRunOnFailed>
      <useDeltaValues>false</useDeltaValues>
      <thresholds>
      <unstableTotalHigh></unstableTotalHigh>
      <unstableTotalNormal></unstableTotalNormal>
      <unstableTotalLow></unstableTotalLow>
      <unstableNewHigh></unstableNewHigh>
      <unstableNewNormal></unstableNewNormal>
      <unstableNewLow></unstableNewLow>
      <failedTotalHigh></failedTotalHigh>
      <failedTotalNormal></failedTotalNormal>
      <failedTotalLow></failedTotalLow>
      <failedNewHigh></failedNewHigh>
      <failedNewNormal></failedNewNormal>
      <failedNewLow></failedNewLow>
      </thresholds>
      <pattern></pattern>
      <parserNames>
      <string>Java Compiler</string>
      </parserNames>
      <ignoreConsole>false</ignoreConsole>
      </hudson.plugins.warnings.WarningsPublisher>

        Issue Links

          Activity

          drulli Ulli Hafner added a comment - - edited

          Which version of the analysis core plugin (Static Analysis Utilities) do you have installed? Is that plugin enabled?

          ingmartinlopez ingmartinlopez added a comment -

          Version 1.14, and that plugin is enabled.

          drulli Ulli Hafner added a comment -

          Hmm, that is strange. There are some fields missing in the serialization.

          Did you recently upgrade the plugin? Does that problem occur for new jobs or only for already existing jobs?

          ingmartinlopez ingmartinlopez added a comment -

          The same problem occurs for new jobs.
          We are having this problem for a long time, I don't remember, but I'm sure is not a problem of the last update of the plugin (this is because I expected the problem to be solved in a couple of updates, but it didn't).

          drulli Ulli Hafner added a comment -

          Since I can't reproduce that issue: Can you please try to download the latest Hudson, start it with java -jar hudson.war (in a clean HUDSON home directory with no jobs) and install only the latest versions of the plug-ins warnings and analysis-core. Restart Hudson and create a new job just with the warnings plugin enabled and see if the config.xml still looks like the above.

          ingmartinlopez ingmartinlopez added a comment -

          I've done that, and it works ok, this is the portion of the generated config.xml:

          <hudson.plugins.warnings.WarningsPublisher>
          <healthy></healthy>
          <unHealthy></unHealthy>
          <thresholdLimit>low</thresholdLimit>
          <pluginName>[WARNINGS] </pluginName>
          <defaultEncoding></defaultEncoding>
          <canRunOnFailed>false</canRunOnFailed>
          <useDeltaValues>false</useDeltaValues>
          <thresholds>
          <unstableTotalAll></unstableTotalAll>
          <unstableTotalHigh></unstableTotalHigh>
          <unstableTotalNormal></unstableTotalNormal>
          <unstableTotalLow></unstableTotalLow>
          <unstableNewAll></unstableNewAll>
          <unstableNewHigh></unstableNewHigh>
          <unstableNewNormal></unstableNewNormal>
          <unstableNewLow></unstableNewLow>
          <failedTotalAll></failedTotalAll>
          <failedTotalHigh></failedTotalHigh>
          <failedTotalNormal></failedTotalNormal>
          <failedTotalLow></failedTotalLow>
          <failedNewAll></failedNewAll>
          <failedNewHigh></failedNewHigh>
          <failedNewNormal></failedNewNormal>
          <failedNewLow></failedNewLow>
          </thresholds>
          <pattern></pattern>
          <parserNames>
          <string>Java Compiler</string>
          </parserNames>
          <ignoreConsole>false</ignoreConsole>
          </hudson.plugins.warnings.WarningsPublisher>

          drulli Ulli Hafner added a comment -

          Good to see, now the serialization of <thresholdLimit>low</thresholdLimit> is ok.

          Maybe another plug-in (or an existing job [less probable]) causes the problem. Can you please install all the other plug-in that you are using in that clean instance? If the problem reappears then one of the other plug-ins is the cause for the problem (and needs to be identified). If that still works then you can try to copy the jobs folder of the broken instance to the working instance...

          ingmartinlopez ingmartinlopez added a comment -

          Ok, I'll do that (it will take me a long time because production server has a LOT of plugins installed), but meanwhile, what do you think of adding a condition that if the serialization fields are missing, default values are considered?

          drulli Ulli Hafner added a comment -

          Well, actually there is such code already present. So I wondered why this code has not been executed on your machine...

          zhh205 zhh205 added a comment -

          I am also having a similar problem with DRY publisher :

           
          [DRY] Collecting duplicate code analysis files...
          [DRY] Successfully parsed file /var/lib/hudson/jobs/.../cpd.xml of module cpd with 48 warnings.
          [DRY] Successfully parsed file /var/lib/hudson/jobs/.../cpd.xml of module cpd with 6 warnings.
          [DRY] Successfully parsed file /var/lib/hudson/jobs/.../cpd.xml of module cpd with 4 warnings.
          [DRY] Successfully parsed file /var/lib/hudson/jobs/.../cpd.xml of module cpd with 10 warnings.
          ERROR: Publisher hudson.plugins.dry.DryPublisher aborted due to exception
          java.lang.NullPointerException: Name is null
          	at java.lang.Enum.valueOf(Enum.java:195)
          	at hudson.plugins.analysis.util.model.Priority.valueOf(Priority.java:18)
          	at hudson.plugins.analysis.core.HealthAwarePublisher.getMinimumPriority(HealthAwarePublisher.java:522)
          	at hudson.plugins.analysis.core.AbstractHealthDescriptor.<init>(AbstractHealthDescriptor.java:36)
          	at hudson.plugins.dry.DryHealthDescriptor.<init>(DryHealthDescriptor.java:25)
          	at hudson.plugins.dry.DryResultAction.<init>(DryResultAction.java:31)
          	at hudson.plugins.dry.DryPublisher.perform(DryPublisher.java:164)
          	at hudson.plugins.analysis.core.HealthAwarePublisher.perform(HealthAwarePublisher.java:280)
          	at hudson.tasks.BuildStepMonitor$2.perform(BuildStepMonitor.java:27)
          	at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:601)
          	at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:580)
          	at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:558)
          	at hudson.model.Build$RunnerImpl.post2(Build.java:157)
          	at hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:528)
          	at hudson.model.Run.run(Run.java:1348)
          	at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
          	at hudson.model.ResourceController.execute(ResourceController.java:88)
          	at hudson.model.Executor.run(Executor.java:139)
          [FINDBUGS] Skipping publisher since build result is FAILURE
          [TASKS] Skipping publisher since build result is FAILURE
          [WARNINGS] Skipping publisher since build result is FAILURE
          [PMD] Skipping publisher since build result is FAILURE
          ERROR: Publisher hudson.plugins.analysis.collector.AnalysisPublisher aborted due to exception
          java.lang.NullPointerException: Name is null
          	at java.lang.Enum.valueOf(Enum.java:195)
          	at hudson.plugins.analysis.util.model.Priority.valueOf(Priority.java:18)
          	at hudson.plugins.analysis.core.HealthAwarePublisher.getMinimumPriority(HealthAwarePublisher.java:522)
          	at hudson.plugins.analysis.core.AbstractHealthDescriptor.<init>(AbstractHealthDescriptor.java:36)
          	at hudson.plugins.analysis.collector.AnalysisHealthDescriptor.<init>(AnalysisHealthDescriptor.java:25)
          	at hudson.plugins.analysis.collector.AnalysisResultAction.<init>(AnalysisResultAction.java:31)
          	at hudson.plugins.analysis.collector.AnalysisPublisher.perform(AnalysisPublisher.java:157)
          	at hudson.plugins.analysis.core.HealthAwarePublisher.perform(HealthAwarePublisher.java:280)
          	at hudson.tasks.BuildStepMonitor$2.perform(BuildStepMonitor.java:27)
          	at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:601)
          	at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:580)
          	at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:558)
          	at hudson.model.Build$RunnerImpl.post2(Build.java:157)
          	at hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:528)
          	at hudson.model.Run.run(Run.java:1348)
          	at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
          	at hudson.model.ResourceController.execute(ResourceController.java:88)
          	at hudson.model.Executor.run(Executor.java:139)
          

          With help of Job Configuration History plugin, I find out that the config.xml has been changed. Although I do not remember that I had explicitly changed anything in the job config page, most probably I just hit the save button. Here are the changes:

           
          --- /var/lib/hudson/jobs/SD4_branch_161/config-history/2010-12-07_14-36-18/config.xml
          +++ /var/lib/hudson/jobs/SD4_branch_161/config-history/2010-12-07_14-36-19/config.xml
          @@ -148,154 +148,153 @@
               <hudson.plugins.dry.DryPublisher>
                 <healthy></healthy>
                 <unHealthy></unHealthy>
          -      <thresholdLimit>low</thresholdLimit>
                 <pluginName>[DRY] </pluginName>
                 <defaultEncoding></defaultEncoding>
                 <canRunOnFailed>false</canRunOnFailed>
          @@ -178,184 +177,182 @@
               <hudson.plugins.findbugs.FindBugsPublisher>
                 <healthy></healthy>
                 <unHealthy></unHealthy>
          -      <thresholdLimit>low</thresholdLimit>
                 <pluginName>[FINDBUGS] </pluginName>
                 <defaultEncoding></defaultEncoding>
                 <canRunOnFailed>false</canRunOnFailed>
          @@ -206,212 +204,209 @@
               <hudson.plugins.tasks.TasksPublisher>
                 <healthy></healthy>
                 <unHealthy></unHealthy>
          -      <thresholdLimit>low</thresholdLimit>
                 <pluginName>[TASKS] </pluginName>
                 <defaultEncoding></defaultEncoding>
                 <canRunOnFailed>false</canRunOnFailed>
          @@ -239,245 +236,241 @@
               <hudson.plugins.warnings.WarningsPublisher>
                 <healthy></healthy>
                 <unHealthy></unHealthy>
          -      <thresholdLimit>low</thresholdLimit>
                 <pluginName>[WARNINGS] </pluginName>
                 <defaultEncoding></defaultEncoding>
                 <canRunOnFailed>false</canRunOnFailed>
          @@ -272,278 +268,273 @@
               <hudson.plugins.pmd.PmdPublisher>
                 <healthy></healthy>
                 <unHealthy></unHealthy>
          -      <thresholdLimit>low</thresholdLimit>
                 <pluginName>[PMD] </pluginName>
                 <defaultEncoding></defaultEncoding>
                 <canRunOnFailed>false</canRunOnFailed>
          @@ -300,306 +295,300 @@
               <hudson.plugins.analysis.collector.AnalysisPublisher>
                 <healthy></healthy>
                 <unHealthy></unHealthy>
          -      <thresholdLimit>low</thresholdLimit>
                 <pluginName>[ANALYSIS-COLLECTOR] </pluginName>
                 <defaultEncoding></defaultEncoding>
                 <canRunOnFailed>true</canRunOnFailed>
          

          Manually changing them back solved the problem.

          Environment: Debian Lenny x86 64Bit, Hudson 1.383, Dry plugin 2.10, Static Analysis Collector Plug-in 1.8, Static Analysis Utilities 1.14)

          drulli Ulli Hafner added a comment -

          Hmm, that is strange. What plug-ins do you have installed?

          zhh205 zhh205 added a comment -

          A complete list of plugins installed:

          Static Analysis Collector Plug-in	1.8	
          Static Analysis Utilities	1.14	
          Audit Trail	1.4		
          Hudson Backup plugin	1.5	
          Bugzilla plugin	1.4	
          Change Log History	1.1		
          Copy Artifact Plugin	1.11	
          Hudson Cron Column Plugin	1.003		
          Hudson CVS Plug-in	1.2	
          Dashboard View	1.8.1	
          Hudson disk-usage plugin	0.12	
          Duplicate Code Scanner Plug-in	2.10	
          Hudson Email Extension Plugin	2.9	
          Hudson Emma plugin	1.21	
          FindBugs Plugin	4.15	
          FTP publisher plugin	1.0	
          Hudson Job Configuration History Plugin	1.5	
          Hudson Locks and Latches plugin	0.6	
          Hudson Mantis plugin	0.10.1	
          Maven 2 Project Plugin	1.374	
          PMD Plug-in	3.10	
          Hudson promoted builds plugin	1.10	
          [deactivated]Promoted Builds (Simple)	1.6		
          Hudson Support Subscription Notification Plugin	1.2		
          SCP plugin	1.6		
          Hudson Sectioned View Plugin	1.12	
          Sidebar Link	1.4		
          Hudson SSH Slaves plugin	0.14	
          Hudson Subversion Plug-in	1.21	
          Subversion Release Manager plugin	1.2	
          Hudson Subversion Tagging Plugin	1.14	
          Task Scanner Plug-in	4.11	
          TestNG Results Plugin	0.8	
          Hudson ViewVC plugin	1.3		
          Warnings Plug-in	3.11	
          
          zhh205 zhh205 added a comment -

          Btw, I'm not able to reproduce the mysterious disappearance by simply click the save button on configuration page.

          zhh205 zhh205 added a comment -

          Sorry for last incomplete input. I'm not able to reproduce the mysterious disappearance of the <thresholdLimit> Tag by simply click the save button on configuration page.

          drulli Ulli Hafner added a comment -

          If you can reproduce this again, please reopen.

          ingmartinlopez ingmartinlopez added a comment -

          I've found the cause of this: an old plugin was installed, and had a dependency with an old version of warnings plugin. That was causing this problem, sorry for the inconvenience.

          xster xster added a comment -

          I am suffering this exception.
          I am adding thresholdLimit element to config.xml of the job by hands.

          drulli Ulli Hafner added a comment -

          Which plug-in versions are you using? Which Jenkins version? What is the exact stacktrace? Why did you change files by hand?

          xster xster added a comment -

          Jenkins 1.439

          Plugins
          Token Macro Plugin 1.4
          Static Code Analysis Plug-ins 1.32
          Warnings Plugin 3.21
          Static Analysis Collector Plug-in 1.18
          Run Condition Plugin 0.6
          conditional-buildstep 0.2
          Flexible Publish Plugin 0.7
          Any Build Step Plugin 0.1
          Jenkins Artifact Deployer Plug-in 0.13
          Avatar Plugin 1.0
          Backup plugin 1.6.1
          Hudson batch task plugin 1.14
          Jenkins Mercurial plugin 1.37
          Jenkins MSBuild Plugin 1.7
          Jenkins Parameterized Trigger plugin 2.12
          Jenkins Post-Build Script Plug-in 0.7
          Jenkins SLOCCount Plug-in 1.6
          SVN Publisher plugin 0.1
          Template Project plugin 1.3
          ThinBackup 1.4
          Jenkins Translation Assistance plugin 1.8

          I am using template project for configuration.
          If I change any settings of template project, the warnings plugin setting lost a configuration value.
          So I edit the job's config.xml to insert the lost value.

          Here is my configuration for the warnings plugin.

          <hudson.plugins.warnings.WarningsPublisher>
          <healthy>0</healthy>
          <unHealthy>1</unHealthy>
          <!-- there should be <thresholdLimit>low</thresholdLimit>, but it's missing -->
          <pluginName>[WARNINGS] </pluginName>
          <defaultEncoding></defaultEncoding>
          <canRunOnFailed>false</canRunOnFailed>
          <useDeltaValues>false</useDeltaValues>
          <thresholds>
          <unstableTotalAll></unstableTotalAll>
          <unstableTotalHigh></unstableTotalHigh>
          <unstableTotalNormal></unstableTotalNormal>
          <unstableTotalLow></unstableTotalLow>
          <unstableNewAll></unstableNewAll>
          <unstableNewHigh></unstableNewHigh>
          <unstableNewNormal></unstableNewNormal>
          <unstableNewLow></unstableNewLow>
          <failedTotalAll></failedTotalAll>
          <failedTotalHigh></failedTotalHigh>
          <failedTotalNormal></failedTotalNormal>
          <failedTotalLow></failedTotalLow>
          <failedNewAll></failedNewAll>
          <failedNewHigh></failedNewHigh>
          <failedNewNormal></failedNewNormal>
          <failedNewLow></failedNewLow>
          </thresholds>
          <shouldDetectModules>false</shouldDetectModules>
          <parserConfigurations/>
          <consoleLogParsers>
          <string>MSBuild</string>
          </consoleLogParsers>
          </hudson.plugins.warnings.WarningsPublisher>

          drulli Ulli Hafner added a comment -

          Hmm, this looks like a bug in the template project...

          drulli Ulli Hafner added a comment -

          Can you please check if removing flexible-publisher and run-condition plug-in solves the problem? (Just to be sure which plugins cause the problems?)

          xster xster added a comment -

          I reinstalled Jenkins to another machine, without flexible-publisher and run-condition.
          Now I don't have any problems.

          drulli Ulli Hafner added a comment -

          Fixed in flexible-publisher plug-in, see JENKINS-12692.


            People

            • Assignee:
              huybrechts huybrechts
              Reporter:
              ingmartinlopez ingmartinlopez
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: