Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-8236

FindBugs Cloud should be visible only to selected projects

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: findbugs-plugin
    • Labels:
      None
    • Similar Issues:

      Description

      The findbugs details screens always show the cloud information links and new this weeks values. Since most of the users of this plug-in will not use the findbugs cloud this fields should be disabled by default. If a projects participates in the FindBugs cloud then the feature could be enabled (if possible automatically).

        Attachments

          Activity

          keithkml keithkml added a comment -

          I'm trying to upload a new FindBugs that fixes this problem. But because of the SVN change, it's not working anymore. I run:

          mvn deploy:deploy-file -Durl=java-net:/maven2-repository/trunk/repository/ -DrepositoryId=maven2-repository.dev.java.net -Dfile=findbugs-full-2.0.0-dev-20101217.jar -DpomFile=upload-pom.xml

          and get this:

          [INFO] Error deploying artifact: Connection failed: Unable to connect to https://svn.dev.java.net/svn/maven2-repository/trunk/repository/

          drulli Ulli Hafner added a comment -

          Keith, I think the issue is fixed now. At least the corresponding plug-in build does not show the icon anymore.

          Can you please have a look at: http://www.faktorzehn.org:8081/job/Hudson%20Plug-ins/156/findbugsResult/source.17/#266
          Seems that you are dereferencing a possible null value.

          Can you please check if you can upload the new version now? I think the repo is fixed again.

          keithkml keithkml added a comment -

          I don't know why, but it just doesn't work. I tried adding -DaltDeploymentRepository=java.net-m2-repository::default::http://maven.hudson-labs.org:8081/content/repositories/releases/ and it still says:

          [INFO] Error deploying artifact: Connection failed: Unable to connect to https://svn.dev.java.net/svn/maven2-repository/trunk/repository/

          I looked at the NPE and I don't see where the error is...and I can't reproduce the warning locally...

          drulli Ulli Hafner added a comment -

          Fixed in 4.17.


            People

            • Assignee:
              keithkml keithkml
              Reporter:
              drulli Ulli Hafner
            • Votes:
              1 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: