Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-8254

Intermittent errors where Perforce plugin can't communicate with Perforce

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Duplicate
    • Component/s: perforce-plugin
    • Labels:
      None
    • Environment:
      Hudson master on RHEL5 x86_64; build slaves on same platform
    • Similar Issues:

      Description

      We're getting multiple errors per day like the following:

      Caught exception communicating with perforce. No output for: p4 describe
      -s 565785 com.tek42.perforce.PerforceException: No output for: p4 describe
      -s 565785
      at
      com.tek42.perforce.parse.AbstractPerforceTemplate.getPerforceResponse(Abstr
      actPerforceTemplate.java:341)
      at com.tek42.perforce.parse.Changes.getChangelist(Changes.java:63)
      at
      com.tek42.perforce.parse.Changes.getChangelistsFromNumbers(Changes.java:381
      )
      at hudson.plugins.perforce.PerforceSCM.checkout(PerforceSCM.java:565)
      at hudson.model.AbstractProject.checkout(AbstractProject.java:1119)
      at
      hudson.model.AbstractBuild$AbstractRunner.checkout(AbstractBuild.java:480)
      at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:412)
      at hudson.model.Run.run(Run.java:1325)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:139)
      ERROR: Unable to communicate with perforce. No output for: p4 describe -s
      565785

      The actual p4 command being executed and the executor that the error happens on can vary, but the error is always
      "Unable to communicate with perforce". It may not even be the first p4 command in the build job. Unfortunately I can't isolate the error any further than that, but I've never seen it happen with a manually started build if that helps.

      If we rerun the build after getting this error it always seems to go through successfully.

      This started to happen after we upgraded to Hudson 1.387 and Perforce plugin 1.1.12. Our previous version was pretty old (Hudson 1.358) if that helps.

        Attachments

          Issue Links

            Activity

            rpetti Rob Petti added a comment -

            Oh, you had written down 1.376 as your hudson version on the mailing list. If you are using >=1.378, then this is a duplicate of JENKINS-7664.

            garethbowles garethbowles added a comment -

            Oops, sorry about the mistake with the version number. I just read through the history of JENKINS-7664; shame, we did the upgrade to 1.387 because it had fixes for some stuck slave problems that we were running into, but it looks like those same remoting fixes have degraded the p4 plugin. I'll keep an eye on progress; thanks for your help.

            rpetti Rob Petti added a comment -

            No worries. I just regret that I can't do much else to help.


              People

              • Assignee:
                rpetti Rob Petti
                Reporter:
                garethbowles garethbowles
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: