Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-8297

Allow packaging of multiple personas as a plugin instead of only one

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Component/s: persona-plugin
    • Labels:
      None
    • Similar Issues:

      Description

      This improvement will allow to package our own plugin with a set of personas and not only one as today.

      Plugin tree will be :

      • my_own_persona.hpi
        • BruceLee
          • persona.xml
          • success.jpg/.png/.gif
          • failure.jpg/.png/.gif
          • other.jpg/.png/.gif
          • icon.jpg/.png/.gif
        • AnotherPersona
          • ... same set of files ...

      In hudson.plugins.persona.xml.XmlPersonaFinder.find(Class<T> type, Hudson hudson) reproducing the same behaviour for "// locate personas from $HUDSON_HOME" block in "// locate personas from plugins" block and adjusting the paths seems to be ok.

        Attachments

        1. persona.hpi
          23 kB
        2. persona.jar
          22 kB
        3. persona.zip
          21 kB

          Activity

          whren whren added a comment -

          Proposed attempt of improvement : 1.2-SNAPSHOT modified
          jar, hpi and source provided

          whren whren added a comment -

          In hudson.plugins.persona.xml.XmlPersonaFinder.find(Class<T> type, Hudson hudson) reproducing the same behaviour for "// locate personas from $HUDSON_HOME" block in "// locate personas from plugins" block and adjusting the paths seems to be ok.


            People

            • Assignee:
              sogabe sogabe
              Reporter:
              whren whren
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: