Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-8299

Unable to "Build now" when remote token is set and token is not included in parameters form

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      Ubuntu 10.10, 32-bit

      Description

      Hudson ver. 1.389.

      = issue 1.1 =
      After the latest update from repository (http://pkg.hudson-labs.org/debian) the Jobs which have a remote token set, can not be built from the www interface.

      The user will be redirected to a page which says:
      "Access Denied

      Invalid token provided."

      In the case that token is passed to HTTP GET
      http://server:8080/job/[jobname]/build?delay=0sec&token=[mytoken]

      The page is displayed

      = issue 1.2 =
      but when the Job has parameters which needs to be set the parameters form does not pass the token value.
      <form name="parameters" action="build?delay=0sec" method="post">

      So when user clicks on Build button the "Invalid Token provided" page will be displayed.

        Issue Links

          Activity

          There are no comments yet on this issue.

            People

            • Assignee:
              Unassigned
              Reporter:
              juhapekka juhapekka
            • Votes:
              5 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: