Details

    • Type: New Feature
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Component/s: cobertura-plugin
    • Labels:
      None
    • Similar Issues:

      Description

      It would be very useful to add support for ratcheting. This would involve making the build job fail or become unstable if the code coverage for a build drops below the code coverage of the previous build. The plugin could keep track of the highest code coverage metrics values from previous builds, and check against this. If the current results are lower, the build fails. If not, the latest values are stored as the new reference values.

      This is very useful for legacy projects, where you want to adopt a Continuous Improvement strategy rather than just imposing a minimum required level of test coverage.

      Thoughts?

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                pwang25 Podar Wang
                Reporter:
                johnsmart johnsmart
              • Votes:
                5 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: