Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-8344

java.lang.ClassNotFoundException: net.bull.javamelody.SessionListener

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: other
    • Labels:
      None
    • Environment:
      Hudson 1.389
      Java 1.6.0_18
    • Similar Issues:

      Description

      I see this in tomcats error.log

      SCHWERWIEGEND: ClassNotFoundException while loading persisted sessions: java.lang.ClassNotFoundException: net.bull.javamelody.SessionListener
      java.lang.ClassNotFoundException: net.bull.javamelody.SessionListener
      at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1666)
      at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1511)
      at java.lang.Class.forName0(Native Method)
      at java.lang.Class.forName(Class.java:247)
      at org.apache.catalina.util.CustomObjectInputStream.resolveClass(CustomObjectInputStream.java:76)
      at java.io.ObjectInputStream.readNonProxyDesc(ObjectInputStream.java:1575)
      at java.io.ObjectInputStream.readClassDesc(ObjectInputStream.java:1496)
      at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1732)
      at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1329)
      at java.io.ObjectInputStream.readObject(ObjectInputStream.java:351)
      at org.apache.catalina.session.StandardSession.readObject(StandardSession.java:1543)
      at org.apache.catalina.session.StandardSession.readObjectData(StandardSession.java:1040)
      at org.apache.catalina.session.StandardManager.doLoad(StandardManager.java:281)
      at org.apache.catalina.session.StandardManager.load(StandardManager.java:201)
      at org.apache.catalina.session.StandardManager.startInternal(StandardManager.java:466)
      at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:139)
      at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:4789)
      at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:139)
      at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:785)
      at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:763)
      at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:557)
      at org.apache.catalina.startup.HostConfig.deployWAR(HostConfig.java:987)
      at org.apache.catalina.startup.HostConfig.deployWARs(HostConfig.java:778)
      at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:540)
      at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1390)
      at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:355)
      at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:119)
      at org.apache.catalina.util.LifecycleBase.fireLifecycleEvent(LifecycleBase.java:89)
      at org.apache.catalina.util.LifecycleBase.setState(LifecycleBase.java:313)
      at org.apache.catalina.util.LifecycleBase.setState(LifecycleBase.java:293)
      at org.apache.catalina.core.ContainerBase.startInternal(ContainerBase.java:996)
      at org.apache.catalina.core.StandardHost.startInternal(StandardHost.java:771)
      at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:139)
      at org.apache.catalina.core.ContainerBase.startInternal(ContainerBase.java:988)
      at org.apache.catalina.core.StandardEngine.startInternal(StandardEngine.java:275)
      at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:139)
      at org.apache.catalina.core.StandardService.startInternal(StandardService.java:427)
      at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:139)
      at org.apache.catalina.core.StandardServer.startInternal(StandardServer.java:649)
      at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:139)
      at org.apache.catalina.startup.Catalina.start(Catalina.java:585)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:288)
      at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:415)
      21.12.2010 11:18:48 org.apache.catalina.session.StandardManager startInternal
      SCHWERWIEGEND: Exception loading sessions from persistent storage
      java.lang.ClassNotFoundException: net.bull.javamelody.SessionListener
      at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1666)
      at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1511)
      at java.lang.Class.forName0(Native Method)
      at java.lang.Class.forName(Class.java:247)
      at org.apache.catalina.util.CustomObjectInputStream.resolveClass(CustomObjectInputStream.java:76)
      at java.io.ObjectInputStream.readNonProxyDesc(ObjectInputStream.java:1575)
      at java.io.ObjectInputStream.readClassDesc(ObjectInputStream.java:1496)
      at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1732)
      at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1329)
      at java.io.ObjectInputStream.readObject(ObjectInputStream.java:351)
      at org.apache.catalina.session.StandardSession.readObject(StandardSession.java:1543)
      at org.apache.catalina.session.StandardSession.readObjectData(StandardSession.java:1040)
      at org.apache.catalina.session.StandardManager.doLoad(StandardManager.java:281)
      at org.apache.catalina.session.StandardManager.load(StandardManager.java:201)
      at org.apache.catalina.session.StandardManager.startInternal(StandardManager.java:466)
      at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:139)
      at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:4789)
      at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:139)
      at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:785)
      at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:763)
      at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:557)
      at org.apache.catalina.startup.HostConfig.deployWAR(HostConfig.java:987)
      at org.apache.catalina.startup.HostConfig.deployWARs(HostConfig.java:778)
      at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:540)
      at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1390)
      at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:355)
      at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:119)
      at org.apache.catalina.util.LifecycleBase.fireLifecycleEvent(LifecycleBase.java:89)
      at org.apache.catalina.util.LifecycleBase.setState(LifecycleBase.java:313)
      at org.apache.catalina.util.LifecycleBase.setState(LifecycleBase.java:293)
      at org.apache.catalina.core.ContainerBase.startInternal(ContainerBase.java:996)
      at org.apache.catalina.core.StandardHost.startInternal(StandardHost.java:771)
      at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:139)
      at org.apache.catalina.core.ContainerBase.startInternal(ContainerBase.java:988)
      at org.apache.catalina.core.StandardEngine.startInternal(StandardEngine.java:275)
      at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:139)
      at org.apache.catalina.core.StandardService.startInternal(StandardService.java:427)
      at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:139)
      at org.apache.catalina.core.StandardServer.startInternal(StandardServer.java:649)
      at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:139)
      at org.apache.catalina.startup.Catalina.start(Catalina.java:585)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:288)
      at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:415)
      21.12.2010 11:18:48 org.apache.catalina.startup.HostConfig deployWAR

        Attachments

          Activity

          evernat evernat added a comment -

          It is caused by the monitoring plugin and not by junit-attachments.

          It happens with Tomcat when authentication is used and when Tomcat restarts. In fact the class of an attribute of the http sessions is not found when Tomcat restarts because the class was loaded in the monitoring plugin and not in Hudson core.

          The consequence of the issue is only that http sessions are not reloaded when Tomcat is stopped then restarted, and also eventually a lot of stack traces in the log file.

          evernat evernat added a comment -

          I have committed a change in trunk of the dependency to fix this.
          See http://code.google.com/p/javamelody/source/detail?r=1678

          It will be included in the version 1.26.0 of the plugin, perhaps in a few weeks.
          If you want to try, I have made a new build of the plugin, including the fix, and it is available at http://javamelody.googlecode.com/files/monitoring.hpi
          You can submit the plugin file in the Advanced tab of the plugin manager.

          Just ask if you have a question and thanks for the issue.


            People

            • Assignee:
              evernat evernat
              Reporter:
              cforce cforce
            • Votes:
              1 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: