Details

    • Similar Issues:

      Description

      Using Olamy's work on integration with maven3 and the cobertura-plugin I get the following exception:
      org.apache.maven.InternalErrorException: Internal error: java.lang.ClassCastException: [Lorg.codehaus.plexus.configuration.PlexusConfiguration; cannot be cast to [Lorg.codehaus.plexus.configuration.xml.XmlPlexusConfiguration;
      at org.apache.maven.lifecycle.internal.BuilderCommon.handleBuildError(BuilderCommon.java:128)
      at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:95)
      at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59)
      at org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183)
      at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161)
      at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:316)
      at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:153)
      at org.jvnet.hudson.maven3.launcher.Maven3Launcher.main(Maven3Launcher.java:78)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.codehaus.plexus.classworlds.launcher.Launcher.launchStandard(Launcher.java:329)
      at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:239)
      at org.jvnet.hudson.maven3.agent.Maven3Main.launch(Maven3Main.java:148)
      at hudson.maven.Maven3Builder.call(Maven3Builder.java:119)
      at hudson.maven.Maven3Builder.call(Maven3Builder.java:69)
      at hudson.remoting.UserRequest.perform(UserRequest.java:114)
      at hudson.remoting.UserRequest.perform(UserRequest.java:48)
      at hudson.remoting.Request$2.run(Request.java:270)
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
      at java.util.concurrent.FutureTask.run(FutureTask.java:138)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      at java.lang.Thread.run(Thread.java:662)
      Caused by: java.lang.ClassCastException: [Lorg.codehaus.plexus.configuration.PlexusConfiguration; cannot be cast to [Lorg.codehaus.plexus.configuration.xml.XmlPlexusConfiguration;
      at hudson.plugins.cobertura.MavenCoberturaPublisher.preExecute(MavenCoberturaPublisher.java:50)
      at hudson.maven.Maven3Builder$MavenExecutionListener.reccordMojoStarted(Maven3Builder.java:463)
      at hudson.maven.Maven3Builder$MavenExecutionListener.forkStarted(Maven3Builder.java:593)
      at org.apache.maven.lifecycle.internal.DefaultExecutionEventCatapult.fire(DefaultExecutionEventCatapult.java:88)
      at org.apache.maven.lifecycle.internal.MojoExecutor.executeForkedExecutions(MojoExecutor.java:314)
      at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:185)
      at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:148)
      at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:140)
      at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:84)
      ... 24 more

      Looks like a ClassLoader issue.

        Attachments

          Activity

          Hide
          olamy Olivier Lamy added a comment -

          can you test fixes with those builds :

          You need both new hudson core and new cobertura plugin version.

          Thanks !

          Show
          olamy Olivier Lamy added a comment - can you test fixes with those builds : http://people.apache.org/~olamy/hudson/main-maven3-support/hudson.war http://people.apache.org/~olamy/hudson/main-maven3-support/cobertura.hpi You need both new hudson core and new cobertura plugin version. Thanks !

            People

            • Assignee:
              olamy Olivier Lamy
              Reporter:
              raresp raresp
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: