Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-8415

M2 and M3 builds behave differently when tests fail

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Component/s: maven-plugin
    • Labels:
      None
    • Environment:
      Hudson 1.392
    • Similar Issues:

      Description

      When running our build with goals and options "-U -fae clean install", Maven 2.2.1 and Maven 3.0.1 gives different results when we have test failures:

      Maven 2: Build is executed to end as expected and reported as 'Unstable'.
      Maven 3: Build is stopped immediately after first test failure as 'Failed'.

        Attachments

          Activity

          olamy olamy added a comment -

          I have some trouble to reproduce this.
          Is it a multimodule build ?

          mpe mpe added a comment -

          Yes, it's a multimodule build with several modules. I'll try to find some more facts (and test with 1.393).

          olamy olamy added a comment -

          Ok I know what to fix. (similar to JENKINS-8362 regarding the cause : incompatibility in maven 3).
          Current workaround is to add -Dmaven.test.failure.ignore=true

          mpe mpe added a comment -

          Ok, great!

          olamy olamy added a comment -
          dogfood dogfood added a comment -

          Integrated in hudson_main_trunk #440
          JENKINS-8415 M2 and M3 builds behave differently when tests fail
          update changelog for JENKINS-8415

          Olivier Lamy :
          Files :

          • maven-plugin/src/main/java/hudson/maven/reporters/SurefireArchiver.java
          • test/src/test/resources/hudson/maven/maven-multimodule-unit-failure.zip
          • test/src/test/java/hudson/maven/MavenBuildSurefireFailedTest.java

          Olivier Lamy :
          Files :

          • changelog.html

            People

            • Assignee:
              olamy olamy
              Reporter:
              mpe mpe
            • Votes:
              1 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: