Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: violations-plugin
    • Labels:
      None
    • Similar Issues:

      Description

      Maven builds fail because of Violation plugin if there is submodules
      There is a missing slash in the submodule path when fetching Violations files

      For example, with a Maven project:

      • parent
        • service
        • presentation
          • webapp
        • dao
          Violation path is presentationwebapp instead of presentation/webapp

      FATAL: /home/workspace/hudson/jobs/esp/workspace/presentationwebapp does not exist.
      /home/workspace/hudson/jobs/esp/workspace/presentationwebapp does not exist.
      at org.apache.tools.ant.types.AbstractFileSet.getDirectoryScanner(AbstractFileSet.java:474)
      at hudson.plugins.violations.ViolationsCollector.findFiles(ViolationsCollector.java:215)
      at hudson.plugins.violations.ViolationsCollector.doType(ViolationsCollector.java:166)
      at hudson.plugins.violations.ViolationsCollector.invoke(ViolationsCollector.java:110)
      at hudson.plugins.violations.ViolationsCollector.invoke(ViolationsCollector.java:27)
      at hudson.FilePath.act(FilePath.java:756)
      at hudson.FilePath.act(FilePath.java:738)
      at hudson.plugins.violations.hudson.maven.ViolationsMavenReporter.end(ViolationsMavenReporter.java:96)
      at hudson.maven.Maven3Builder.end(Maven3Builder.java:207)
      at hudson.maven.MavenModuleSetBuild$RunnerImpl.doRun(MavenModuleSetBuild.java:626)
      at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:417)
      at hudson.model.Run.run(Run.java:1362)
      at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:400)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:145)

        Attachments

          Issue Links

            Activity

            aeris22 aeris22 created issue -
            aeris22 aeris22 made changes -
            Field Original Value New Value
            Description Maven builds fail because of Violation plugin if there is submodules
            There is a missing slash in the submodule path when fetching Violations files

            For example, with a Maven project:
            parent
             \_ presentation
                 \_ webapp
            Violation path is presentationwebapp instead of presentation/webapp

            FATAL: /home/workspace/hudson/jobs/esp/workspace/*presentationwebapp* does not exist.
            /home/workspace/hudson/jobs/esp/workspace/*presentationwebapp* does not exist.
            at org.apache.tools.ant.types.AbstractFileSet.getDirectoryScanner(AbstractFileSet.java:474)
            at hudson.plugins.violations.ViolationsCollector.findFiles(ViolationsCollector.java:215)
            at hudson.plugins.violations.ViolationsCollector.doType(ViolationsCollector.java:166)
            at hudson.plugins.violations.ViolationsCollector.invoke(ViolationsCollector.java:110)
            at hudson.plugins.violations.ViolationsCollector.invoke(ViolationsCollector.java:27)
            at hudson.FilePath.act(FilePath.java:756)
            at hudson.FilePath.act(FilePath.java:738)
            at hudson.plugins.violations.hudson.maven.ViolationsMavenReporter.end(ViolationsMavenReporter.java:96)
            at hudson.maven.Maven3Builder.end(Maven3Builder.java:207)
            at hudson.maven.MavenModuleSetBuild$RunnerImpl.doRun(MavenModuleSetBuild.java:626)
            at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:417)
            at hudson.model.Run.run(Run.java:1362)
            at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:400)
            at hudson.model.ResourceController.execute(ResourceController.java:88)
            at hudson.model.Executor.run(Executor.java:145)
            Maven builds fail because of Violation plugin if there is submodules
            There is a missing slash in the submodule path when fetching Violations files

            For example, with a Maven project:
            * parent
            ** service
            ** presentation
            *** webapp
            ** dao
            Violation path is presentationwebapp instead of presentation/webapp

            {quote}FATAL: /home/workspace/hudson/jobs/esp/workspace/*presentationwebapp* does not exist.
            /home/workspace/hudson/jobs/esp/workspace/*presentationwebapp* does not exist.
            at org.apache.tools.ant.types.AbstractFileSet.getDirectoryScanner(AbstractFileSet.java:474)
            at hudson.plugins.violations.ViolationsCollector.findFiles(ViolationsCollector.java:215)
            at hudson.plugins.violations.ViolationsCollector.doType(ViolationsCollector.java:166)
            at hudson.plugins.violations.ViolationsCollector.invoke(ViolationsCollector.java:110)
            at hudson.plugins.violations.ViolationsCollector.invoke(ViolationsCollector.java:27)
            at hudson.FilePath.act(FilePath.java:756)
            at hudson.FilePath.act(FilePath.java:738)
            at hudson.plugins.violations.hudson.maven.ViolationsMavenReporter.end(ViolationsMavenReporter.java:96)
            at hudson.maven.Maven3Builder.end(Maven3Builder.java:207)
            at hudson.maven.MavenModuleSetBuild$RunnerImpl.doRun(MavenModuleSetBuild.java:626)
            at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:417)
            at hudson.model.Run.run(Run.java:1362)
            at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:400)
            at hudson.model.ResourceController.execute(ResourceController.java:88)
            at hudson.model.Executor.run(Executor.java:145){quote}
            olamy olamy made changes -
            Link This issue duplicates JENKINS-8418 [ JENKINS-8418 ]
            olamy olamy added a comment -

            which hudson version are you using ? (1.391 ?)

            aeris22 aeris22 added a comment - - edited

            Same problem on 1.392 and your custom 1.393 (JENKINS-8362)
            Maven version is 3.0 (not try on 2.1.1)

            olamy olamy added a comment -

            You will have this with maven 2.2.1
            before 1.392 which version did you use ?
            I have reproduce with 1.391 too.

            aeris22 aeris22 added a comment - - edited

            I use 1.382 and 1.386 before (2 hudson instances, same problem)
            And I try with a fresh 1.392 install, same problem too

            Globally, upgrade to or fresh install from 1.391 or upper break all builds, new Maven 3.0 jobs (seems «normal» considering young 3.X support) but (and it's very much blocking) old 2.X too (violations, mirrors, settings and cobertura problems in my cases)

            olamy olamy added a comment -

            will be in 1.394

            olamy olamy made changes -
            Status Open [ 1 ] Closed [ 6 ]
            Assignee peterkittreilly [ peterkittreilly ] olamy [ olamy ]
            Fix Version/s current [ 10162 ]
            Resolution Fixed [ 1 ]
            dogfood dogfood added a comment -

            Integrated in hudson_main_trunk #422

            olamy olamy added a comment -

            reopen as not fixed after more tests.

            olamy olamy made changes -
            Resolution Fixed [ 1 ]
            Status Closed [ 6 ] Reopened [ 4 ]
            olamy olamy made changes -
            Status Reopened [ 4 ] Closed [ 6 ]
            Resolution Fixed [ 1 ]
            dogfood dogfood added a comment -

            Integrated in hudson_main_trunk #427
            JENKINS-8452 Bad Path for submodules
            JENKINS-8452 really ensure we use the scm checkout path

            Olivier Lamy :
            Files :

            • maven-plugin/src/main/java/hudson/maven/MavenModuleSetBuild.java

            Olivier Lamy :
            Files :

            • maven-plugin/src/main/java/hudson/maven/MavenModuleSetBuild.java
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 138562 ] JNJira + In-Review [ 204810 ]

              People

              • Assignee:
                olamy olamy
                Reporter:
                aeris22 aeris22
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: