Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-8539

If first choice is a blank line, it gets removed when returning to Configure the project

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Won't Fix
    • Component/s: other
    • Labels:
      None
    • Environment:
      Running windows server 2010, appears to happen in most/all browsers.
    • Similar Issues:

      Description

      1. Create a new project
      2. Check "This build is parameterized"
      3. Add a choice variable
      4. Enter a name for it in the "Name" field
      5. In the "Choices" box, enter 4 items like so, such that the first item is a blank line:

      A
      B
      C
      6. Click Save
      7. Click Configure
      8. The first (blank) line has been removed so the choices are now:
      A
      B
      C

      It appears that a workaround is to use a space as the first line, but this will not be a possible option for many projects.

        Attachments

          Issue Links

            Activity

            Hide
            oleg_nenashev Oleg Nenashev added a comment -
            Show
            oleg_nenashev Oleg Nenashev added a comment - Closing the issue according to the discussion in https://wiki.jenkins-ci.org/display/JENKINS/2014+JIRA+Components+Refactoring
            Hide
            mchristy Marshall Christy added a comment -

            I'm Seeing the same behavior running on Ubuntu server. On the projects that I've had a blank line on, I just re-add it when I need to change the project. It only affects the project if you save it with the blank line missing, and only removes the blank line when you go the the "Configure" page.

            Show
            mchristy Marshall Christy added a comment - I'm Seeing the same behavior running on Ubuntu server. On the projects that I've had a blank line on, I just re-add it when I need to change the project. It only affects the project if you save it with the blank line missing, and only removes the blank line when you go the the "Configure" page.

              People

              • Assignee:
                kohsuke Kohsuke Kawaguchi
                Reporter:
                demogorgonx demogorgonx
              • Votes:
                3 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: