Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-8559

CppCheck links to last success or unstable build, even when the current build fails due to CppCheck errors

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: cppcheck-plugin
    • Labels:
      None
    • Environment:
      Running on Hudson 1.386.
    • Similar Issues:

      Description

      The link provided by CppCheck Plugin links currently always to the last success or unstable build.

      I configured the build to fail when CppCheck found errors.
      This works fine, the build fails.

      But then I want to examine the found errors from CppCheck.
      But this is not possible as the link directs to an old build (or even to no build when never a build was successful).

      I would want CppCheck to link to direct allways to the last run build (this keeps also the source code links in sync with the displayed errors)

        Attachments

          Activity

          gbois Gregory Boissinot added a comment -

          Could you try again with the latest version?
          Thanks

          martinro martinro added a comment - - edited

          Tested again with Plugin Version 0.13.
          Starting point: All previous builds where stable, last build number is #185.
          Next build #186: Marked unstable due to cppcheck errors. Link to cppcheck errors is ok to build #186
          Next build #187: Marked still as unstable due to cppcheck errors. Link to cppcheck errors is now NOT OK. Links to build #185!

          gbois Gregory Boissinot added a comment -

          I didn't reproduce the problem because I can't find where there is the problem.
          Where do you see that there is a link to a previous build?

          martinro martinro added a comment -

          Marked the link with the problem

          martinro martinro added a comment -

          Added screenshot1.jpg.
          The marked hyperlink links to (for example) http://dehudson:8080/view/C++Builder/job/0000-001%20C++Builder%20DE_PssHtmlReportService/cppcheckResult.
          I think this link should open the results of the last build with cppcheck results (no matter of stable, unstable or even failed).
          But sometimes it seems to link to the last stable build , but that can be a old build.

          I hope this explains the issue a little bit better.

          gbois Gregory Boissinot added a comment -

          Fixed in Cppcheck 0.14

          mixalturek Michal Turek added a comment -

          Closing.


            People

            • Assignee:
              gbois Gregory Boissinot
              Reporter:
              martinro martinro
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: