Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-8572

Credentials visable in UI and configuration gets corrupted

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Duplicate
    • Component/s: m2release-plugin
    • Labels:
      None
    • Environment:
      Hudson: 1.385
      m2release plugin: 0.6.1
      Maven: 2.2.1
    • Similar Issues:

      Description

      After triggering a release build, the whole commandline is visable in the original maven build section - including the SCM credentials!

      Reproduce:

      • configure release plugin (see attachement "befor_release.jpg")
      • start a release build
      • define SCM credentials
      • trigger build
      • wait 1 minute
      • open the jobs configuration
      • check the build configuration -> you'll find the credentials in the "Goals and options" field of the Build section (not the one from the release plugin configuration - see attachement "while_building.jpg")

      Strange enough, we even had cases where this values where persistet to the configuration!

      unfortunatly this is an absolut killer for this plugin.

        Attachments

          Issue Links

            Activity

            teilo James Nord added a comment -

            duplicate of JENKINS-8524


              People

              • Assignee:
                teilo James Nord
                Reporter:
                domi Dominik Bartholdi
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: