Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: maven-plugin
    • Labels:
      None
    • Similar Issues:
      Show 5 results

      Description

      Version 1.395:

      At Apache, we have 1.395, and a maven 3.0.2 install configured. I set up a build, and got the following. Note the nonfunctional google groups email address, by the way.

      At revision 1062467
      no change for https://svn.apache.org/repos/asf/webservices/xmlschema/trunk since the previous build
      Unpacking https://archive.apache.org/dist/maven/binaries/apache-maven-3.0.2-bin.tar.gz to /home/hudson/hudson-slave/tools/Maven_3.0 on ubuntu1
      ERROR: Processing failed due to a bug in the code. Please report this to hudson-users@googlegroups.com
      java.lang.IllegalArgumentException: /home/hudson/hudson-slave/tools/Maven_3.0 without lib directory
      	at hudson.maven.MavenEmbedderUtils.buildClassRealm(MavenEmbedderUtils.java:81)
      	at hudson.maven.MavenEmbedderUtils.getMavenVersion(MavenEmbedderUtils.java:170)
      	at hudson.maven.MavenVersionCallable.call(MavenVersionCallable.java:56)
      	at hudson.maven.MavenVersionCallable.call(MavenVersionCallable.java:40)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:114)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:48)
      	at hudson.remoting.Request$2.run(Request.java:270)
      	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
      	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
      	at java.lang.Thread.run(Thread.java:636)
      project=hudson.maven.MavenModuleSet@4f54cc7c[xmlschema-new-trunk-jdk15-native-m3]
      project.getModules()=[]
      project.getRootModule()=null
      FATAL: /home/hudson/hudson-slave/tools/Maven_3.0 without lib directory
      java.lang.IllegalArgumentException: /home/hudson/hudson-slave/tools/Maven_3.0 without lib directory
      	at hudson.maven.MavenEmbedderUtils.buildClassRealm(MavenEmbedderUtils.java:81)
      	at hudson.maven.MavenEmbedderUtils.getMavenVersion(MavenEmbedderUtils.java:170)
      	at hudson.maven.MavenVersionCallable.call(MavenVersionCallable.java:56)
      	at hudson.maven.MavenVersionCallable.call(MavenVersionCallable.java:40)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:114)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:48)
      	at hudson.remoting.Request$2.run(Request.java:270)
      	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
      	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
      	at java.lang.Thread.run(Thread.java:636)
      

        Attachments

          Issue Links

            Activity

            bimargulies bimargulies created issue -
            Hide
            olamy olamy added a comment -

            Hello,
            Does it concerns the build here : https://hudson.apache.org/hudson/job/xmlschema-new-trunk-jdk15/ ?

            Show
            olamy olamy added a comment - Hello, Does it concerns the build here : https://hudson.apache.org/hudson/job/xmlschema-new-trunk-jdk15/ ?
            Hide
            olamy olamy added a comment -

            btw all looks to be fine here : https://hudson.apache.org/hudson/job/xmlschema-new-trunk-jdk15-native-m3/

            so is there really an issue ?

            Show
            olamy olamy added a comment - btw all looks to be fine here : https://hudson.apache.org/hudson/job/xmlschema-new-trunk-jdk15-native-m3/ so is there really an issue ?
            Hide
            bimargulies bimargulies added a comment -

            At this point, just the broken google group email address diagnosis of what was a problem local to the Apache instance.

            Also, that latter build (which was the issue) failed over and over before succeeding, and I can't explain why.

            Show
            bimargulies bimargulies added a comment - At this point, just the broken google group email address diagnosis of what was a problem local to the Apache instance. Also, that latter build (which was the issue) failed over and over before succeeding, and I can't explain why.
            Hide
            kutzi kutzi added a comment -

            The "without lib directory" issue seems to be the same as JENKINS-9241

            Show
            kutzi kutzi added a comment - The "without lib directory" issue seems to be the same as JENKINS-9241
            kutzi kutzi made changes -
            Field Original Value New Value
            Status Open [ 1 ] Resolved [ 5 ]
            Resolution Duplicate [ 3 ]
            kutzi kutzi made changes -
            Link This issue duplicates JENKINS-9241 [ JENKINS-9241 ]
            ircbot Jenkins IRC Bot made changes -
            Component/s maven-plugin [ 16033 ]
            Component/s maven2 [ 15487 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 138697 ] JNJira + In-Review [ 188114 ]

              People

              • Assignee:
                Unassigned
                Reporter:
                bimargulies bimargulies
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: