Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-8818

PMD results history grap wipedout on build failure

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: pmd-plugin, remoting
    • Labels:
      None
    • Environment:
      OS - Snow Leopard
      Hardware - XServer
      Master-Slave configuration
      PMD - v3.10
      Hudson - 1.381
    • Similar Issues:

      Description

      When a job fails, the PMD Trend chart (in the dashboard of the job) goes blank.
      The old build PMD statistics also get wiped out.
      Any pointers to resolutions of this issue will be highly appreciated.

      Thanks in advance.
      -Srini

        Attachments

          Activity

          srini sp s added a comment -

          Any luck on this issue?

          Seeing below exception while executing PMD

          Module pmd: Parsing of file /Volumes/ngs//hudson-slave/workspace/XXX/XXX/reports/code-analysis/pmd/pmd.xml failed due to an exception: org.xml.sax.SAXParseException: The entity "ufffd" was referenced, but not declared. at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1269) at org.apache.commons.digester.Digester.parse(Digester.java:1666) at hudson.plugins.pmd.parser.PmdParser.parse(PmdParser.java:71) at hudson.plugins.analysis.core.AbstractAnnotationParser.parse(AbstractAnnotationParser.java:52) at hudson.plugins.analysis.core.FilesParser.parseFile(FilesParser.java:197) at hudson.plugins.analysis.core.FilesParser.parseFiles(FilesParser.java:176) at hudson.plugins.analysis.core.FilesParser.invoke(FilesParser.java:126) at hudson.plugins.analysis.core.FilesParser.invoke(FilesParser.java:29) at hudson.FilePath$FileCallableWrapper.call(FilePath.java:1899) at hudson.remoting.UserRequest.perform(UserRequest.java:114) at hudson.remoting.UserRequest.perform(UserRequest.java:48) at hudson.remoting.Request$2.run(Request.java:270) at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:417) at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:269) at java.util.concurrent.FutureTask.run(FutureTask.java:123) at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:651) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:676) at hudson.remoting.Engine$1$1.run(Engine.java:58) at java.lang.Thread.run(Thread.java:613)

          evernat evernat added a comment -

          Is it reproduced with recent versions?

          drulli Ulli Hafner added a comment -

          Please reopen if that happens again.


            People

            • Assignee:
              drulli Ulli Hafner
              Reporter:
              srini sp s
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: