Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-8841

ProcessTreeKiller error loading winp.dll

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Environment:
      OS: Windows 7 Professional x86 or Windows 2003 Server SP2
      Java: jdk1.6.0 x86
    • Similar Issues:

      Description

      Simulation:

      1. Create a job called "TESTE" with the Windows command: notepad.exe
      2. Start your job "TESTE", check that Notepad is started (dont close).
      3. Cancel the build of the job "TESTE" and see that Notepad is still open.
      4. Check the stacktrace on the server console, as attached file.

      Problem:
      When you cancel a build, the process that started don't closes.

      Workaround:
      1. Copy the file "WEB-INF\lib\winp.dll" to the directory "C:\Windows\system32" and restart the server.

      PS: ProcessTreeKiller is enabled.

        Attachments

          Issue Links

            Activity

            panga Leonardo Zanivan created issue -
            panga Leonardo Zanivan made changes -
            Field Original Value New Value
            Due Date 2011-02-21 00:00:00.0
            evernat evernat added a comment -

            according to the following page, you need to use the system property: "-Dhudson.util.ProcessTree.disable=true" (or "-Dhudson.util.ProcessTreeKiller.disable=true").

            See https://wiki.jenkins-ci.org/display/JENKINS/ProcessTreeKiller

            Is it still an issue for you?

            panga Leonardo Zanivan added a comment -

            Yes, its still a issue for me.

            PS: ProcessTreeKiller is enabled.

            The problem is with that the JNI library isn't loading.

            oleg_nenashev Oleg Nenashev made changes -
            Link This issue is duplicated by JENKINS-18320 [ JENKINS-18320 ]
            oleg_nenashev Oleg Nenashev added a comment -

            JENKINS-20913 should resolve the issue.
            The DLL loading seems seems to be stable since hudson.remoting 2.35

            oleg_nenashev Oleg Nenashev made changes -
            Link This issue duplicates JENKINS-20913 [ JENKINS-20913 ]
            danielbeck Daniel Beck added a comment -

            Agreed, let's consider this a duplicate of JENKINS-8841 for now and wait for reports disputing that on 1.558.

            danielbeck Daniel Beck made changes -
            Status Open [ 1 ] Resolved [ 5 ]
            Resolution Duplicate [ 3 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 138985 ] JNJira + In-Review [ 188269 ]

              People

              • Assignee:
                Unassigned
                Reporter:
                panga Leonardo Zanivan
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: