Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-8904

Git plug-in assumes Git has submodule command

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: git-plugin
    • Labels:
      None
    • Environment:
      RHEL 4u6, Jenkins 1.3.96, Jenkins Git 1.1.5, Git 1.7.0
    • Similar Issues:

      Description

      After upgrading to version 1.1.5 of the Git plug-in, our jobs on machines with Git 1.7.0 have started breaking since the Git plug-in issues "submodule" commands, which this version of Git apparently does not support.

      It fails like this:
      hudson.plugins.git.GitException: Error performing command: /ld/env/bin/git submodule init
      Command "/ld/env/bin/git submodule init" returned status code 1: git: 'submodule' is not a git-command. See 'git --help'.

      We don't even use submodules, so there's no reason for Jenkins to bother in the first place?

        Attachments

          Issue Links

            Activity

            abayer Andrew Bayer added a comment -

            git 1.7.0 definitely should have submodule - not sure why yours doesn't. Also, that command should only be getting called if there's a ".gitmodules" file in your repo in the first place - could you try this with version 1.1.6 of the git plugin?

            aknuds1 Arve Knudsen added a comment -

            I can't understand why there'd be a .gitmodules in our repo considering we've never used that functionality. Anyway, I can't reproduce the issue with 1.1.6 and Git 1.7.0, so I guess we might as well consider it fixed.

            zaytsev Yury Zaytsev added a comment -

            If JENKINS-6658 issue can be fixed (pull request to be merged), then this can be used for a workaround for this issue and it can be closed.

            zaytsev Yury Zaytsev added a comment -

            This is now resolved in master, you can test plugin snapshot from here:

            http://ci.jenkins-ci.org/job/plugins_git-plugin/260/


              People

              • Assignee:
                abayer Andrew Bayer
                Reporter:
                aknuds1 Arve Knudsen
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: