Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-9074

Disable the "Exclude element CHECKEDOUT" option when checking the "Use snaphost view" checkbox

    Details

    • Similar Issues:

      Description

      When defining the UCM Baseline parameter, if the Exclude element CHECKEDOUT is checked, the job systematically fails when creating the view's config spec.
      The error message is :

      — config spec start —
      element "/mts_tools/HudsonAdm/..." B_HUDSONADM_V01_E24 -nocheckout
      element * /main/0 -ucm -nocheckout
      load /mts_tools/HudsonAdm/Controler
      — config spec end —
      [HUDSON_CTRL_B_HUDSONADM_V01_E24] $ /usr/atria/bin/cleartool setcs -tag HUDSON_CTRL_B_HUDSONADM_V01_E24 ../configspec50873.txt
      cleartool: Error: The first element rule of a snapshot view's config spec must be "element * CHECKEDOUT".
      cleartool: Error: Config spec semantic processing failed.
      cleartool: Error: Unable to change configuration specification: error in configuration specification.
      FATAL: ClearCase UCM baseline failed. exit code=1

      Note that it works correctly if the checkbox is not checked. But it means that we cannot ensure that checkedout versions are not loaded, which is a critical problem when building or testing stable configuration.

        Attachments

          Activity

          jlpinardon jlpinardon created issue -
          jlpinardon jlpinardon made changes -
          Field Original Value New Value
          Summary Job systematic failuer when selecting Exclude element CHECKEDOUT from the UCM Baseline build parameter Job systematic failure when selecting Exclude element CHECKEDOUT from the UCM Baseline build parameter
          rseguy Romain Seguy made changes -
          Status Open [ 1 ] In Progress [ 3 ]
          rseguy Romain Seguy added a comment -

          Hey Jean-Luc,

          I don't think this is a bug: The error occurs becuse CC's snapshot views must have the element * CHECKEDOUT instruction. To not have it, you need to use a dynamic view. Also, if you're using CCLT, element * CHECKEDOUT must always be there.

          HTH,
          Romain

          jlpinardon jlpinardon added a comment - - edited

          Hi Romain,

          I just have tried to create a snapshot view, then I suppressed the element * CHECKEDOUT rule.
          I obtained the following error :
          The first element rule of a snapshot view's config spec must be "element * CHECKEDOUT"

          So, OK... it is not a bug.
          But It would be more user friendly if the R/O option disappeared when selecting a snapshot view... No idea if it is feasible or not...

          rseguy Romain Seguy made changes -
          Summary Job systematic failure when selecting Exclude element CHECKEDOUT from the UCM Baseline build parameter Disable the "Exclude element CHECKEDOUT" option when checking the "Use snaphost view" checkbox
          rseguy Romain Seguy made changes -
          Issue Type Bug [ 1 ] Improvement [ 4 ]
          Priority Critical [ 2 ] Minor [ 4 ]
          rseguy Romain Seguy added a comment -

          OK. I've renamed the issue to reflect the need to disable the option when using a snapshot view (actually this is explained in the inline help but it's true that it's not visible). I'll try to see what I can do on the UI side. Not sure I can deactivate the checkbox, but I should be able to at least display a warning message.

          rseguy Romain Seguy added a comment -

          Fixed by using a warning message; Will be shipped with next release

          rseguy Romain Seguy made changes -
          Status In Progress [ 3 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          rseguy Romain Seguy made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: rseguy
          Path:
          src/main/java/com/michelin/cio/hudson/plugins/clearcaseucmbaseline/ClearCaseUcmBaselineParameterDefinition.java
          src/main/resources/com/michelin/cio/hudson/plugins/clearcaseucmbaseline/ClearCaseUcmBaselineParameterDefinition.properties
          src/main/resources/com/michelin/cio/hudson/plugins/clearcaseucmbaseline/ClearCaseUcmBaselineParameterDefinition_fr.properties
          http://jenkins-ci.org/commit/clearcase-ucm-baseline-plugin/afc215c66739166d57e90236e8469fc815a495da
          Log:
          [FIXED JENKINS-9074] Disable the "Exclude element CHECKEDOUT" option when checking the "Use snaphost view" checkbox

          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 139219 ] JNJira + In-Review [ 204960 ]

            People

            • Assignee:
              rseguy Romain Seguy
              Reporter:
              jlpinardon jlpinardon
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: