Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-9213

Noisy "ERROR" logging related to Token Macro plugin

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: maven-plugin
    • Labels:
      None
    • Environment:
      Jenkins 1.404; both Maven 2.2.1 and Maven 3.0.2
    • Similar Issues:
      Show 5 results

      Description

      Since upgrading to Jenkins 1.404 (from 1.399), I'm seeing the following message multiple times in every Maven 2 or Maven 3 build:

      ERROR: Ignore Problem expanding maven opts macros org.jenkinsci.plugins.tokenmacro.TokenMacro

      Note that our Jenkins does NOT have the Token Macro plugin installed.

      A quick Google search implies that this changeset may be to blame: https://github.com/jenkinsci/jenkins/pull/68

      Since we are not using the Token Macro plugin, it's a little disconcerting to be getting "ERROR" level messages related to it from the core Maven plugin, especially several times in a single log.

        Attachments

          Issue Links

            Activity

            victor_bronstein victor_bronstein added a comment - - edited

            Also, seeing the following exception in jenkins.err.log at the time of startup. Perhaps being caused by the same problem. I have the email-ext plugin installed (that AFAIU uses the Token Macro plugin), but the Token Macro plugin itself is not explicitly installed.

            Apr 3, 2011 10:30:08 AM hudson.ExtensionFinder$Sezpoz scout
            WARNING: Failed to scout com.nirima.jenkins.token.RepositoryTokenMacro
            java.lang.InstantiationException: java.lang.NoClassDefFoundError: org/jenkinsci/plugins/tokenmacro/DataBoundTokenMacro
            	at net.java.sezpoz.IndexItem.element(IndexItem.java:133)
            	at hudson.ExtensionFinder$Sezpoz.scout(ExtensionFinder.java:206)
            	at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:277)
            	at hudson.ExtensionList.load(ExtensionList.java:237)
            	at hudson.ExtensionList.ensureLoaded(ExtensionList.java:208)
            	at hudson.ExtensionList.iterator(ExtensionList.java:115)
            	at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:276)
            	at hudson.ExtensionList.load(ExtensionList.java:237)
            	at hudson.ExtensionList.ensureLoaded(ExtensionList.java:208)
            	at hudson.ExtensionList.iterator(ExtensionList.java:115)
            	at hudson.model.Hudson.getDescriptorByType(Hudson.java:1002)
            	at hudson.plugins.copyartifact.BuildSelectorParameter.initAliases(BuildSelectorParameter.java:100)
            	at hudson.plugins.copyartifact.CopyArtifactPlugin.postInitialize(CopyArtifactPlugin.java:35)
            	at hudson.PluginManager$2$1$2.run(PluginManager.java:291)
            	at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:146)
            	at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
            	at hudson.model.Hudson$4.runTask(Hudson.java:734)
            	at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
            	at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
            	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
            	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
            	at java.lang.Thread.run(Unknown Source)
            Caused by: java.lang.NoClassDefFoundError: org/jenkinsci/plugins/tokenmacro/DataBoundTokenMacro
            	at java.lang.ClassLoader.defineClass1(Native Method)
            	at java.lang.ClassLoader.defineClassCond(Unknown Source)
            	at java.lang.ClassLoader.defineClass(Unknown Source)
            	at java.security.SecureClassLoader.defineClass(Unknown Source)
            	at java.net.URLClassLoader.defineClass(Unknown Source)
            	at java.net.URLClassLoader.access$000(Unknown Source)
            	at java.net.URLClassLoader$1.run(Unknown Source)
            	at java.security.AccessController.doPrivileged(Native Method)
            	at java.net.URLClassLoader.findClass(Unknown Source)
            	at java.lang.ClassLoader.loadClass(Unknown Source)
            	at java.lang.ClassLoader.loadClass(Unknown Source)
            	at hudson.PluginManager$UberClassLoader.findClass(PluginManager.java:636)
            	at java.lang.ClassLoader.loadClass(Unknown Source)
            	at java.lang.ClassLoader.loadClass(Unknown Source)
            	at net.java.sezpoz.IndexItem.element(IndexItem.java:121)
            	... 21 more
            Caused by: java.lang.ClassNotFoundException: org.jenkinsci.plugins.tokenmacro.DataBoundTokenMacro
            	at java.net.URLClassLoader$1.run(Unknown Source)
            	at java.security.AccessController.doPrivileged(Native Method)
            	at java.net.URLClassLoader.findClass(Unknown Source)
            	at java.lang.ClassLoader.loadClass(Unknown Source)
            	at java.lang.ClassLoader.loadClass(Unknown Source)
            	... 36 more
            
            matfiz Konstantin Spirin added a comment -

            I'm seeing the following:

            Apr 4, 2011 12:04:15 PM hudson.ExtensionFinder$Sezpoz find
            WARNING: Failed to load hudson.plugins.groovy.GroovyTokenMacro
            java.lang.InstantiationException: java.lang.NoClassDefFoundError: org/jenkinsci/plugins/tokenmacro/DataBoundTokenMacro
            at net.java.sezpoz.IndexItem.element(IndexItem.java:133)
            at hudson.ExtensionFinder$Sezpoz.find(ExtensionFinder.java:142)
            at hudson.ExtensionFinder._find(ExtensionFinder.java:92)
            at hudson.ExtensionList.load(ExtensionList.java:259)
            at hudson.ExtensionList.ensureLoaded(ExtensionList.java:216)
            at hudson.ExtensionList.iterator(ExtensionList.java:113)
            at hudson.tools.ToolLocationNodeProperty.getToolHome(ToolLocationNodeProperty.java:98)
            at hudson.tools.ToolInstallation.translateFor(ToolInstallation.java:149)
            at hudson.model.JDK.forNode(JDK.java:111)
            at hudson.model.AbstractBuild.getEnvironment(AbstractBuild.java:697)
            at hudson.tasks.CommandInterpreter.perform(CommandInterpreter.java:75)
            at hudson.tasks.CommandInterpreter.perform(CommandInterpreter.java:58)
            at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:19)
            at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:603)
            at hudson.model.Build$RunnerImpl.build(Build.java:172)
            at hudson.model.Build$RunnerImpl.doRun(Build.java:137)
            at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:417)
            at hudson.model.Run.run(Run.java:1362)
            at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
            at hudson.model.ResourceController.execute(ResourceController.java:88)
            at hudson.model.Executor.run(Executor.java:145)
            Caused by: java.lang.NoClassDefFoundError: org/jenkinsci/plugins/tokenmacro/DataBoundTokenMacro
            at java.lang.ClassLoader.defineClass1(Native Method)
            at java.lang.ClassLoader.defineClassCond(ClassLoader.java:632)
            at java.lang.ClassLoader.defineClass(ClassLoader.java:616)
            at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
            at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
            at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
            at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
            at java.security.AccessController.doPrivileged(Native Method)
            at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
            at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
            at java.lang.ClassLoader.loadClass(ClassLoader.java:248)
            at hudson.PluginManager$UberClassLoader.findClass(PluginManager.java:622)
            at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
            at java.lang.ClassLoader.loadClass(ClassLoader.java:248)
            at net.java.sezpoz.IndexItem.element(IndexItem.java:121)
            ... 20 more
            Caused by: java.lang.ClassNotFoundException: org.jenkinsci.plugins.tokenmacro.DataBoundTokenMacro
            at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
            at java.security.AccessController.doPrivileged(Native Method)
            at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
            at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
            at java.lang.ClassLoader.loadClass(ClassLoader.java:248)
            ... 35 more

            liya Liya Katz added a comment -

            It also seems like this error makes our build to failed although everything finished with SUCCESS

            olamy olamy added a comment -

            I wonder if you could upgrade to 1.405 (I have pushed some fixes regarding this)
            https://github.com/jenkinsci/jenkins/commit/c2cd2d11f27a517f1aef2a3e3f933032bb3ddfeb

            liya Liya Katz added a comment -

            still got these warnings in the log in 1.405, but it doesn't change the status of the build now - changing the priority back to minor

            kaguendiez Jonathan Gonzalez added a comment -

            I have the same Error with in the 1.406

            kreyssel Conny Kreyßel added a comment -

            Same here in 1.407.

            cpelander Chad Pelander added a comment -

            Another in 1.407

            dpryden Daniel Pryden added a comment - - edited

            ...and I'll add that I can still see the same issue in 1.408, as well.

            Is there something else I can attach to help with debugging this issue?

            willemv Willem Verstraeten added a comment - - edited

            I'm also still seeing this in 1.408, in freestyle builds by the way.

            leojhartiv leojhartiv added a comment -

            Just to confirm, this is also failing our builds even though Maven, etc are reporting success.

            carlspring carlspring added a comment -

            Also seen in 1.413.

            drulli Ulli Hafner added a comment -

            I think you need to wrap the code that uses the token macro plug-in into a separate class. There you can catch class not found exceptions. (Or you make the dependency required)

            olamy olamy added a comment -

            don't really understand : maven buid failed due to this or you complain only with the error message in the log ?

            dpryden Daniel Pryden added a comment -

            @olamy: I've never seen this actually fail any build. Because it is often written at the end of the log and contains the word "ERROR", it is often noticed first when looking for the cause of a failed build, but upon further investigation we've always found some other reason. But I opened this ticket because the error message is there every time.

            Other commenters here are saying that this is causing their builds to fail. My guess is that there is probably some other issue (possibly introduced at around the same time) that is causing the build to fail. I would assume that fixing this logging issue will probably make the other issue more clear, however, so it seems like a reasonable first step.

            bishiboosh Valentin Rocher added a comment -

            Just to be clear, it didn't fail any build here either, it's just the error message that was bothering me.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Olivier Lamy
            Path:
            maven-plugin/src/main/java/hudson/maven/MavenBuild.java
            maven-plugin/src/main/java/hudson/maven/MavenModuleSetBuild.java
            http://jenkins-ci.org/commit/jenkins/04f22dc69919af26a9b90b466144b46f6a79df7c
            Log:
            [FIXED JENKINS-9213] as we ignore the non available TokenMacro no need to log that

            leojhartiv leojhartiv added a comment -

            It did appear to fail my build. It seemed to happen after there was 1 or more legitimate failures. Once the build was "fixed" I could see Maven resporting "SUCCESS", but ultimately the build failed. The only error message was related to the above. Hopefully the fix you've introduced will reveal more.

            Thanks!

            dogfood dogfood added a comment -
            stynor Steve Tynor added a comment -

            I still see this behavior on Jenkins 1.418 (released today).

            kflorian kflorian added a comment -

            Yep, seeing this too in 1.418.

            kutzi kutzi added a comment -

            Looks like the 1st release including this fix was 1.419

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Olivier Lamy
            Path:
            maven-plugin/src/main/java/hudson/maven/MavenBuild.java
            maven-plugin/src/main/java/hudson/maven/MavenModuleSetBuild.java
            http://jenkins-ci.org/commit/jenkins/04f22dc69919af26a9b90b466144b46f6a79df7c
            Log:
            [FIXED JENKINS-9213] as we ignore the non available TokenMacro no need to log that

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Olivier Lamy
            Path:
            maven-plugin/src/main/java/hudson/maven/MavenBuild.java
            maven-plugin/src/main/java/hudson/maven/MavenModuleSetBuild.java
            http://jenkins-ci.org/commit/jenkins/04f22dc69919af26a9b90b466144b46f6a79df7c
            Log:
            [FIXED JENKINS-9213] as we ignore the non available TokenMacro no need to log that

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Olivier Lamy
            Path:
            src/main/java/hudson/maven/MavenBuild.java
            src/main/java/hudson/maven/MavenModuleSetBuild.java
            http://jenkins-ci.org/commit/maven-plugin/5b492e84b0d61c8398f1af910b91209904929e34
            Log:
            [FIXED JENKINS-9213] as we ignore the non available TokenMacro no need to log that

            Originally-Committed-As: 04f22dc69919af26a9b90b466144b46f6a79df7c


              People

              • Assignee:
                olamy olamy
                Reporter:
                dpryden Daniel Pryden
              • Votes:
                23 Vote for this issue
                Watchers:
                20 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: