Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-9236

Jenkins update using apt-get on Ubuntu breaks installations due to /var/lib/jenkins ownership

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Not A Defect
    • Component/s: core
    • Labels:
      None
    • Environment:
      Ubuntu 10.10 tomcat6
    • Similar Issues:
      Show 5 results

      Description

      Jenkins is installed using distribution (apt-get install jenkins) but is configured to run inside tomcat6.

      In order to preserve default package location I added a symlink from /usr/share/tomcat6/.jenkins to /var/lib/jenkins

      After this I change the default ownership for the /var/lib/jenkins from jenkins:adm to tomcat6:tomcat6

      The problem is that after each Jenkins upgrade the server will refuse to restart because the permissions on the /var/lib/jenkins are reset and as a direct result it will fail to start because it cannot write to the /var/lib/jenkinks directory.

        Attachments

          Issue Links

            Activity

            ssbarnea Sorin Sbarnea added a comment -

            BTW, the group `adm` does not exist on Ubuntu - I tried to add user tomcat6 to the group adm but it failed because adm does not exist.

            resmo René Moser added a comment - - edited

            There is a adm group in Ubuntu default installations: "members of adm are allowed to view some logfiles". However, IMHO the user jenkins should be in a new created group jenkins not adm. But from my point of view, this is not a bug.

            ssbarnea Sorin Sbarnea added a comment -

            This clearly an important issue when running Jenkins under Ubuntu.

            Now the question is if this is caused by the distribution or by jenkins and what can we do in order to assure that Jenkins is properly upgraded using the aptitude/apt.

            I am not sure if Jenkins contains service files in the distribution or if running jenkins outside tomcat could have other side effects.

            danielbeck Daniel Beck added a comment -

            This is not a bug. Don't install using apt-get when running the war inside Tomcat afterwards.

            Or just, you know, change the Jenkins username and group in /etc/default/jenkins.


              People

              • Assignee:
                Unassigned
                Reporter:
                ssbarnea Sorin Sbarnea
              • Votes:
                1 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: