Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-9311

CVS tags should be useable as job parameters (just like SVN tags)

    Details

    • Type: New Feature
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: cvs-plugin
    • Labels:
      None
    • Similar Issues:

      Description

      The Subversion plug-in supports this since version 1.24:
      "Added a new job parameter allowing to dynamically list svn tags."

      It would be great to have this feature also for CVS SCMs.

        Attachments

          Activity

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: mc1arke
          Path:
          src/main/java/hudson/scm/CvsChangeSet.java
          src/main/java/hudson/scm/CvsLog.java
          src/main/java/hudson/scm/CvsTagsParamDefinition.java
          src/main/java/hudson/scm/CvsTagsParamValue.java
          src/main/resources/hudson/scm/CvsTagsParamDefinition/config.jelly
          src/main/resources/hudson/scm/CvsTagsParamDefinition/help-cvsTagsParam.html
          src/main/resources/hudson/scm/CvsTagsParamDefinition/help-moduleName.html
          src/main/resources/hudson/scm/CvsTagsParamDefinition/help-name.html
          src/main/resources/hudson/scm/CvsTagsParamDefinition/index.jelly
          src/main/resources/hudson/scm/CvsTagsParamValue/value.jelly
          src/main/resources/hudson/scm/cvs/Messages.properties
          http://jenkins-ci.org/commit/cvs-plugin/50165bf777a14f60be12f25d0a4928daa8269ea0
          Log:
          Add job parameter to dynamically list available CVS symbolic names for a module
          [FIXED JENKINS-9311] Support CVS tags as job params

          fredg Fred G added a comment -

          Sorry, this is not a duplicate of JENKINS-3812.
          I guess my description was a bit misleading.

          What I meant was a special type of job parameter (like the string parameter, file parameter, etc.).
          The Subversion plug-in provides a job parameter, that let's the user choose the revision to check out. It would be nice to have the same kind of job parameter for the CVS plug-in.

          This used to be rather hard, because the underlying Ant library did not directly support listing the available tags of a specific CVS module. Hopefully the NetBeans CVS client library supports this natively.


            People

            • Assignee:
              mc1arke Michael Clarke
              Reporter:
              fredg Fred G
            • Votes:
              3 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: