Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-9338

Continuous Integration game stops updating scores after resetting scores

    Details

    • Type: Bug
    • Status: Open (View Workflow)
    • Priority: Major
    • Resolution: Unresolved
    • Component/s: ci-game-plugin
    • Labels:
      None
    • Environment:
      Jenkins 1.405, Continuous Integration game 1.18
    • Similar Issues:

      Description

      We've seen the following problem a couple of times: after resetting scores to zero, the plugin no longer updates the scores. A build with no changes that would have been worth a single point, for example, now is worth zero points after performing the reset.

      The problem may resolve itself after a Hudson/Jenkins restart, but I cannot confirm that, although the first time this happened the problem suddenly fixed itself, and I suspect it was due to a restart. The current occurrence has not yet been followed by a restart to verify that. If we do a restart and it suddenly starts working I will update this report.

        Attachments

          Activity

          Hide
          dankirkd Daniel Kirkdorffer added a comment -

          After a restart the plugin continues to not work. We've had to stop using it.

          Show
          dankirkd Daniel Kirkdorffer added a comment - After a restart the plugin continues to not work. We've had to stop using it.
          Hide
          redsolo redsolo added a comment -

          Hi I just tried to reproduce the problem but wasnt able to. Is there any exceptions shown in either the builds console or in the jenkins log? Could you share some more info about your setup?

          Heres what I did trying to reproduce it:

          1. Start jenkins 405
          2. Create a job
            1. Job polls a git repo so I can get a user in the scores list
            2. Enabled cigame in it
          3. Started a build and verified that it received 1 points
          4. Pushed a change to the git repo
          5. Started a build, and verified that a user was added to the score list with 1
          6. reset the score
          7. Started a new build, and verified that it was worth 1 points

          Is this the scenario you were seeing?

          Show
          redsolo redsolo added a comment - Hi I just tried to reproduce the problem but wasnt able to. Is there any exceptions shown in either the builds console or in the jenkins log? Could you share some more info about your setup? Heres what I did trying to reproduce it: Start jenkins 405 Create a job Job polls a git repo so I can get a user in the scores list Enabled cigame in it Started a build and verified that it received 1 points Pushed a change to the git repo Started a build, and verified that a user was added to the score list with 1 reset the score Started a new build, and verified that it was worth 1 points Is this the scenario you were seeing?
          Hide
          dankirkd Daniel Kirkdorffer added a comment -

          We were just using the plugin against a couple of jobs. We noticed that at times it would just cease to work. It seemed to happen after resetting the scores, but not all the time. So I can't be completely sure of all the variables at play for you to repro it.

          Show
          dankirkd Daniel Kirkdorffer added a comment - We were just using the plugin against a couple of jobs. We noticed that at times it would just cease to work. It seemed to happen after resetting the scores, but not all the time. So I can't be completely sure of all the variables at play for you to repro it.

            People

            • Assignee:
              redsolo redsolo
              Reporter:
              dankirkd Daniel Kirkdorffer
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: