Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-9564

Nested Repeatable dropbox change values when used back/forward buttons in Chrome

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Environment:
      Linux, Tomcat 6.0.29
    • Similar Issues:

      Description

      In configure page, when it have nested repeatable drop-box, the values changed if used back forward navigation buttons.
      The problem occurs only in Chrome browser(checked with IE and FF). The problem is that if i press save button , the wrong values are saved. Moreover , the HTML itself is right , with right selected options.
      I stored the configure page as file, and deployed it to Tomcat. The static page don't have same problems. as dynamic.

      Steps for reproduce:
      1.Download jenkins.war from http://ftp-nyc.osuosl.org/pub/jenkins/war/1.410/jenkins.war
      2.Deploy to Tomcat
      3.Download Post build task from http://hudson-ci.org/downloads/plugins/postbuild-task/1.8/ and install it
      NOTE: this plug-in used as example. You can use any other plug-in with nested repeatable drop-box field.
      4.Create free-style job
      5 Go to Configure page and add configure "Post build task" option as illustrated in plugin page:
      http://wiki.hudson-ci.org/display/HUDSON/Post+build+task
      6.Save the configuration.
      7.Go to configuration page by using link in side panel. Go to "Post build task". The values in dropboxes are as expected.
      8.press Back navigator button and then forward button. The values in top drop-box was changed(see attached screen shots)

        Attachments

        1. after.jpg
          after.jpg
          22 kB
        2. before.jpg
          before.jpg
          22 kB

          Issue Links

            Activity

            kr1chard Keith Richardson added a comment - - edited

            Step #9. Press save. The incorrect configuration is now saved to jobs config.xml.

            This bug belongs to core (not plugin) because it is reproducible with any nested repeatable. The choice of using post build task plugin to demonstrate the bug was arbitrary.

            danielbeck Daniel Beck added a comment -

            Duplicates JENKINS-18435 (that issue has more watchers and indicates it's still a problem).


              People

              • Assignee:
                Unassigned
                Reporter:
                jekuku Evgeny Bokov
              • Votes:
                1 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: