Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-9569

NPE after adding and removing cloudbees-deployer

    Details

    • Similar Issues:

      Description

      We added (and saved), then removed the cloudbees-deployer plugin from a build. Then, when we ran the job, it failed with this error:

      Found mavenVersion 2.2.1 from file jar:file:/opt/maven/apache-maven-2.2.1/lib/maven-2.2.1-uber.jar!/META-INF/maven/org.apache.maven/maven-core/pom.properties
      ERROR: Processing failed due to a bug in the code. Please report this to jenkins-users@googlegroups.com
      java.lang.NullPointerException
      at hudson.model.AbstractBuild$AbstractRunner.preBuild(AbstractBuild.java:667)
      at hudson.maven.MavenModuleSetBuild$RunnerImpl.doRun(MavenModuleSetBuild.java:555)
      at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:431)
      at hudson.model.Run.run(Run.java:1362)
      at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:432)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:145)

      Looking at the config.xml for the job, I see this:

      <publishers>
      <null/>
      </publishers>

      It's not clear to me if this is a bug in the plugin or Jenkins itself.

        Attachments

          Activity

          Hide
          olamy Olivier Lamy added a comment -

          not used anymore

          Show
          olamy Olivier Lamy added a comment - not used anymore

            People

            • Assignee:
              olamy Olivier Lamy
              Reporter:
              recampbell Ryan Campbell
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: