Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-976

Maven build hangs when trying to fetch external resources.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: maven-plugin
    • Labels:
      None
    • Environment:
      Platform: PC, OS: Windows XP
    • Similar Issues:

      Description

      I know this have been reported before, but I though I'd fill in with some
      additional information.

      I am trying to build our Maven2 multi project with Hudson, but it just hangs
      while trying to fetch artifacts from external repositories. The same build works
      fine from the commandline.

      I tried with Maven 2.0.4, Maven 2.0.6 and Maven 2.0.7 all with the same result.

      Here is what the console log shows:

      $ java -cp "C:\Documents and Settings\bjacobse\Local
      Settings\Temp\winstone\hudson.war\WEB-INF\lib\maven-agent-1.150.jar;C:\Program
      Files\maven-2.0.4\core\boot\classworlds-1.1.jar" hudson.maven.agent.Main
      "C:\Program Files\maven-2.0.4" "C:\Documents and Settings\bjacobse\Local
      Settings\Temp\winstone\hudson.war\WEB-INF\lib\remoting-1.150.jar" "C:\Documents
      and Settings\bjacobse\Local
      Settings\Temp\winstone\hudson.war\WEB-INF\lib\maven-interceptor-1.150.jar"
      channel started
      [INFO] Scanning for projects...
      [INFO] Reactor build order:
      [INFO] ip-functions
      [INFO] ip-code-translator
      [INFO] ip-code-service-rar
      [INFO] ip-code-service-ws
      [INFO] ip-exceptions
      [INFO] ip-logging
      [INFO] ip-logging-servlet
      [INFO] ip-soapfault-interpreter
      [INFO] ip-errorhandler-logging
      [INFO] ip-errorhandler
      [INFO] ip-bulls-logservice
      [INFO] ip-bulls-eventservice
      [INFO] ip-test-tse-logging
      [INFO] ip-testservice
      [INFO] test-webservices
      [INFO] bulls-webservices
      [INFO] ip-code-translator-rar
      [INFO] ip-alsb-logging
      Downloading:
      http://repo1.maven.org/maven2/org/apache/axis2/maven2/axis2-aar-maven-plugin/1.1/axis2-aar-maven-plugin-1.1.pom

      When I then eventually abort the job I get this stacktrace:

      ERROR: Aborted
      java.lang.InterruptedException
      at java.lang.Object.wait(Native Method)
      at java.lang.Object.wait(Object.java:485)
      at hudson.remoting.Request.call(Request.java:88)
      at hudson.remoting.Channel.call(Channel.java:272)
      at hudson.maven.MavenModuleSetBuild$RunnerImpl.doRun(MavenModuleSetBuild.java:309)
      at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:192)
      at hudson.model.Run.run(Run.java:601)
      at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:172)
      at hudson.model.ResourceController.execute(ResourceController.java:70)
      at hudson.model.Executor.run(Executor.java:62)
      finished: FAILURE

        Attachments

          Issue Links

            Activity

            tblack tblack added a comment -

            Created an attachment (id=197)
            from delayed maven hangup

            tblack tblack added a comment -

            I have a similar experience in Hudson 1.200, although the hang is not
            indefinite, it only lasts exactly two minutes. The resource maven was looking
            for was:
            Downloading:
            http://10.5.5.82:8081/artifactory/repo/org/apache/ws/commons/XmlSchema/1.1/XmlSchema-1.1.pom

            A few notes:
            1) outside of hudson, maven will spend less than a second on this download attempt
            2) we use a maven cache server, artifactory
            3) the <version> in the pom does not match the actual 1.1 version implied in the
            path. this is the reason why artifactory cannot handle the pom properly, so
            every maven run will attempt to download the pom ad nauseam.

            I captured the maven monitor thread dump during the 2 minute hangup and attached
            to this issue.

            jergan jergan added a comment -

            I am not sure that this is relevant, but I have problems with the maven
            assembly-plugin when running Maven projects using Hudson.
            When the plugin is to read the assembly descriptor xml file, located in the
            myproejct/src/assembler directory, Hudson hangs for several minutes.
            When running outside Hudson, this works without problems.
            The problem is reproducable.

            I use:

            • Hudson 1.205
            • Maven 2.0.8
            • JDK 1.6.0_01
            • Windows XP.

            (Running with this configuration, I also experience the problem that you
            describe (Hudson hangs when downloading artifacts).)

            karlmdavis karlmdavis added a comment -

            Created an attachment (id=246)
            This is the thread dump from my Maven2 build. It hangs while downloading a POM and never recovers. The hanging seems to happen at different POMs, randomly.

            kohsuke Kohsuke Kawaguchi added a comment -

            I believe this is the same as issue #1458, which was fixed in Hudson 1.219.

                • This issue has been marked as a duplicate of 1458 ***

              People

              • Assignee:
                Unassigned
                Reporter:
                bjacobse bjacobse
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: