Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-9864

Test harness sometime fail on OSX with "I/O error in channel Channel to child process"

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Incomplete
    • Component/s: core
    • Labels:
      None
    • Environment:
      OSX Snow Leopard, Apple Java 6, Maven 3.0.3
    • Similar Issues:

      Description

      [INFO] --- maven-junit-plugin:1.9:test (default) @ jenkins-test-harness ---
      channel started
      Ping failed. Terminating
      3 juin 2011 08:47:38 hudson.remoting.Channel$ReaderThread run
      GRAVE: I/O error in channel Channel to child process port:55010
      java.io.IOException: Unexpected termination of the channel
      	at hudson.remoting.Channel$ReaderThread.run(Channel.java:998)
      Caused by: java.io.EOFException
      	at java.io.ObjectInputStream$BlockDataInputStream.peekByte(ObjectInputStream.java:2553)
      	at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1296)
      	at java.io.ObjectInputStream.readObject(ObjectInputStream.java:350)
      	at hudson.remoting.Channel$ReaderThread.run(Channel.java:992)
      java.util.concurrent.ExecutionException: hudson.remoting.RequestAbortedException: hudson.remoting.RequestAbortedException: java.io.IOException: Unexpected termination of the channel
      	at java.util.concurrent.FutureTask$Sync.innerGet(FutureTask.java:232)
      	at java.util.concurrent.FutureTask.get(FutureTask.java:91)
      	at com.sun.maven.junit.TestMojo.executeForked(TestMojo.java:333)
      	(...)
      	at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:352)
      Caused by: hudson.remoting.RequestAbortedException: hudson.remoting.RequestAbortedException: java.io.IOException: Unexpected termination of the channel
      	at hudson.remoting.Request.call(Request.java:137)
      	at hudson.remoting.Channel.call(Channel.java:643)
      	at com.sun.maven.junit.LocalTestCaseRunner.copyTo(LocalTestCaseRunner.java:170)
      	at com.sun.maven.junit.TestMojo$1Port.<init>(TestMojo.java:263)
      	at com.sun.maven.junit.TestMojo$1Task.call(TestMojo.java:285)
      	at com.sun.maven.junit.TestMojo$1Task.call(TestMojo.java:272)
      	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:138)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      	at java.lang.Thread.run(Thread.java:680)
      Caused by: hudson.remoting.RequestAbortedException: java.io.IOException: Unexpected termination of the channel
      	at hudson.remoting.Request.abort(Request.java:257)
      	at hudson.remoting.Channel.terminate(Channel.java:694)
      	at com.sun.maven.junit.TestMojo$1.terminate(TestMojo.java:441)
      	at hudson.remoting.Channel$ReaderThread.run(Channel.java:1016)
      Caused by: java.io.IOException: Unexpected termination of the channel
      	at hudson.remoting.Channel$ReaderThread.run(Channel.java:998)
      Caused by: java.io.EOFException
      	at java.io.ObjectInputStream$BlockDataInputStream.peekByte(ObjectInputStream.java:2553)
      	at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1296)
      	at java.io.ObjectInputStream.readObject(ObjectInputStream.java:350)
      	at hudson.remoting.Channel$ReaderThread.run(Channel.java:992)
      
      

        Attachments

          Issue Links

            Activity

            brianharris brianharris added a comment -

            Suspected duplicate of JENKINS-6817

            evernat evernat added a comment -

            Hi Nicolas,
            Do you have reproduced the issue recently?

            evernat evernat added a comment -

            No response from the reporter (Nicolas), so resolving as incomplete.


              People

              • Assignee:
                Unassigned
                Reporter:
                ndeloof Nicolas De Loof
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: