Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-9881

BoostTestJunitHudsonTestType and its getDescriptor() points to two different instances

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: xunit-plugin
    • Labels:
      None
    • Environment:
      Windows 7, Tomcat 7.0.12
    • Similar Issues:
      Show 5 results

      Description

      Looking in the system log, I found the following warning:

      1-jun-2011 15:09:21 hudson.model.Descriptor verifyNewInstance
      WARNING: Father of com.thalesgroup.dtkit.metrics.hudson.model.BoostTestJunitHudsonTestType@7d996e and its getDescriptor() points to two different instances. Probably malplaced @Extension. See http://hudson.361315.n4.nabble.com/Help-Hint-needed-Post-build-action-doesn-t-stay-activated-td2308833.html
      1-jun-2011 15:10:30 hudson.model.Descriptor verifyNewInstance
      WARNING: Father of com.thalesgroup.dtkit.metrics.hudson.model.BoostTestJunitHudsonTestType@cf7781 and its getDescriptor() points to two different instances. Probably malplaced @Extension. See http://hudson.361315.n4.nabble.com/Help-Hint-needed-Post-build-action-doesn-t-stay-activated-td2308833.html

        Attachments

          Activity

          gbois Gregory Boissinot added a comment -

          Thanks for reporting this issue.
          It's strange.
          The location of the @Extension annotation is not very strong.

          Do you have again the same problem on the latest version with a recent Jenkins version?

          gbois Gregory Boissinot added a comment -

          Can't reproduce


            People

            • Assignee:
              gbois Gregory Boissinot
              Reporter:
              rioch rioch
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: