Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-9929

Jenkins Maven Release Plug-in fails to commit modified pom.xml files into svn

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Incomplete
    • Component/s: m2release-plugin
    • Labels:
      None
    • Environment:
      Ubuntu 11.04 (GNU/Linux 2.6.38-8-virtual x86_64)
      Jenkins ver. 1.414

      Plugins:
      cvs 1.2 true false
      m2release 0.7.1 true false
      maven-plugin 1.414 true false
      ssh-slaves 0.15 true false
      subversion 1.25

      Description

      The rest of the build process is working fine. Jenkins uses the same settings to checkout the project from svn. It just fails when it tries to check in the modified pom.xml files at the end of the release:prepare step.

      I also noticed these warnings that I'm not sure about. Could they be the cause? I don't really know what they mean.

      Started by user woozlebuild
      Updating http://svnhost/woozle/test6/dev/trunk/vault
      At revision 3705
      no change for http://svnhost/woozle/test6/dev/trunk/vault since the previous build
      Found mavenVersion 2.2.1 from file jar:file:/usr/share/maven2/lib/maven-debian-uber.jar!/META-INF/maven/org.apache.maven/maven-core/pom.properties
      Parsing POMs
      [workspace] $ /usr/lib/jvm/java-6-sun/bin/java -cp /var/lib/jenkins/plugins/maven-plugin/WEB-INF/lib/maven-agent-1.2.jar:/usr/share/maven2/boot/classworlds.jar hudson.maven.agent.Main /usr/share/maven2 /var/run/jenkins/war/WEB-INF/lib/remoting-1.414.jar /var/lib/jenkins/plugins/maven-plugin/WEB-INF/lib/maven-interceptor-1.2.jar 56145
      <===[HUDSON REMOTING CAPACITY]===>channel started
      Executing Maven: -B -f /var/lib/jenkins/jobs/1116test/workspace/pom.xml -Dpassword=********* -Dusername=woozlebuild -Dresume=false release:prepare release:perform
      [WARNING]

                            • WARNING ************

      This Maven runtime contains a LifecycleExecutor component with an incomplete configuration.

      LifecycleExecutor class: org.apache.maven.lifecycle.LifecycleExecutorInterceptor
      Missing component requirement: org.apache.maven.project.MavenProjectBuilder

      NOTE: This seems to be a third-party Maven derivative you are using. If so, please
      notify the developers for this derivative project of the problem. The Apache Maven team is not
      responsible for maintaining the integrity of third-party component overrides.

      [WARNING]

                            • WARNING ************

      This Maven runtime contains a LifecycleExecutor component with an incomplete configuration.

      LifecycleExecutor class: org.apache.maven.lifecycle.LifecycleExecutorInterceptor
      Missing component requirement: org.apache.maven.project.interpolation.ModelInterpolator

      NOTE: This seems to be a third-party Maven derivative you are using. If so, please
      notify the developers for this derivative project of the problem. The Apache Maven team is not
      responsible for maintaining the integrity of third-party component overrides.

      [WARNING]

                            • WARNING ************

      This Maven runtime contains a LifecycleExecutor component with an incomplete configuration.

      LifecycleExecutor class: org.apache.maven.lifecycle.LifecycleExecutorInterceptor
      Missing component requirement: org.apache.maven.ConfigurationInterpolator

      NOTE: This seems to be a third-party Maven derivative you are using. If so, please
      notify the developers for this derivative project of the problem. The Apache Maven team is not
      responsible for maintaining the integrity of third-party component overrides.

      [INFO] Scanning for projects...
      [INFO] Reactor build order:
      [INFO] Common
      [INFO] docs
      [INFO] vault
      [INFO] Searching repository for plugin with prefix: 'release'.
      [INFO] ------------------------------------------------------------------------
      [INFO] Building vault
      [INFO] task-segment: [release:prepare, release:perform] (aggregator-style)
      [INFO] ------------------------------------------------------------------------

      [REMOVED ALL THE BUILD OUTPUT]

      [INFO] [INFO] BUILD SUCCESSFUL
      [INFO] [INFO] ------------------------------------------------------------------------
      [INFO] [INFO] Total time: 40 seconds
      [INFO] [INFO] Finished at: Thu Jun 09 16:30:09 UTC 2011
      [INFO] [INFO] Final Memory: 62M/631M
      [INFO] [INFO] ------------------------------------------------------------------------
      [INFO] Checking in modified POMs...
      [INFO] Executing: /bin/sh -c cd /var/lib/jenkins/jobs/1116test/workspace && svn --username woozlebuild --password '*****' --non-interactive commit --file /tmp/maven-scm-659489675.commit --targets /tmp/maven-scm-6087889816584398883-targets
      [INFO] Working directory: /var/lib/jenkins/jobs/1116test/workspace
      [JENKINS] Archiving /var/lib/jenkins/jobs/1116test/workspace/pom.xml to /var/lib/jenkins/jobs/1116test/modules/veeva.ecm$vault/builds/2011-06-09_16-29-17/archive/veeva.ecm/vault/1.5.0.13-SNAPSHOT/vault-1.5.0.13-SNAPSHOT.pom
      [INFO] ------------------------------------------------------------------------
      [ERROR] BUILD FAILURE
      [INFO] ------------------------------------------------------------------------
      [INFO] Unable to commit files
      Provider message:
      The svn command failed.
      Command output:
      svn: Commit failed (details follow):
      svn: OPTIONS of 'http://svnhost/woozle/test6/dev/trunk/vault': authorization failed: Could not authenticate to server: rejected Basic challenge (http://svnhost)

        Activity

        petehayes Peter Hayes added a comment -

        This looks like an m2release issue

        dallwardtveeva Derek Allwardt added a comment -

        Are you saying the maven is broken?

        I had all of this working (exact same svn repo, code, etc...) with the test install of Jenkins on my Mac. After I installed Jenkins on Ubuntu, I encounter this problem.

        petehayes Peter Hayes added a comment -

        No. I reassigned to the m2release plugin component in JIRA.

        teilo James Nord added a comment -

        does your passowrd have any quotes or spaces?
        Could you try with an account that doesn't?

        from the slave node (and workspace)
        what happens if you run (after the failed build)
        svn --username woozlebuild --password somepassowd --non-interactive commit

        evernat evernat added a comment -

        No response from the reporter, so closing as incomplete.


          People

          • Assignee:
            teilo James Nord
            Reporter:
            dallwardtveeva Derek Allwardt
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: