Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-9950

ERROR: Failed to clean the workspace

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Cannot Reproduce
    • Component/s: other
    • Labels:
      None
    • Similar Issues:

      Description

      We are using Jenkins 1.406 here (until now, 1.406 has been working fine – so better to use something you know works rather than risking upgrading to something that might not) we have started seeing this randomly on our builders:

      Started by upstream project "lustre-reviews" build number 920
      Building remotely on rhel5-64-build
      Checkout:inkernel / /var/lib/jenkins/workspace/lustre-reviews/arch/x86_64/build_type/client/distro/el5/ib_stack/inkernel - hudson.remoting.Channel@9b72734:rhel5-64-build
      Using strategy: Gerrit Trigger
      Last Built Revision: Revision aa2ff9e8ecb9bf44f3ba06fa159812587fb4a86b (null)
      Checkout:inkernel / /var/lib/jenkins/workspace/lustre-reviews/arch/x86_64/build_type/client/distro/el5/ib_stack/inkernel - hudson.remoting.LocalChannel@6c1f6177
      Cloning the remote Git repository
      Cloning repository origin
      ERROR: Failed to clean the workspace
      java.io.IOException: Unable to delete /var/lib/jenkins/workspace/lustre-reviews/arch/x86_64/build_type/client/distro/el5/ib_stack/inkernel
      	at hudson.Util.deleteFile(Util.java:263)
      	at hudson.Util.deleteRecursive(Util.java:305)
      	at hudson.FilePath$9.invoke(FilePath.java:825)
      	at hudson.FilePath$9.invoke(FilePath.java:823)
      	at hudson.FilePath.act(FilePath.java:757)
      	at hudson.FilePath.act(FilePath.java:739)
      	at hudson.FilePath.deleteRecursive(FilePath.java:823)
      	at hudson.plugins.git.GitAPI.clone(GitAPI.java:168)
      	at hudson.plugins.git.GitSCM$2.invoke(GitSCM.java:864)
      	at hudson.plugins.git.GitSCM$2.invoke(GitSCM.java:812)
      	at hudson.FilePath$FileCallableWrapper.call(FilePath.java:1944)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:118)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:48)
      	at hudson.remoting.Request$2.run(Request.java:270)
      	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
      	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
      	at hudson.remoting.Engine$1$1.run(Engine.java:59)
      	at java.lang.Thread.run(Thread.java:636)
      ERROR: Error cloning remote repo 'origin' : Failed to delete workspace
      ERROR: Cause: Unable to delete /var/lib/jenkins/workspace/lustre-reviews/arch/x86_64/build_type/client/distro/el5/ib_stack/inkernel
      Trying next repository
      ERROR: Could not clone repository
      FATAL: Could not clone
      hudson.plugins.git.GitException: Could not clone
      	at hudson.plugins.git.GitSCM$2.invoke(GitSCM.java:880)
      	at hudson.plugins.git.GitSCM$2.invoke(GitSCM.java:812)
      	at hudson.FilePath$FileCallableWrapper.call(FilePath.java:1944)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:118)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:48)
      	at hudson.remoting.Request$2.run(Request.java:270)
      	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
      	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
      	at hudson.remoting.Engine$1$1.run(Engine.java:59)
      	at java.lang.Thread.run(Thread.java:636)
      

      When I examine the workspace, it's an empty directory and yet there are previous builds in this same workspace.

      Any ideas as to what is going wrong?

        Attachments

          Issue Links

            Activity

            brian Brian Murrell created issue -
            mandeepr Mandeep Rai added a comment -

            Does your job have the "Execute concurrently if necessary" option checked? or maybe a custom workspace?

            mandeepr Mandeep Rai made changes -
            Field Original Value New Value
            Link This issue is related to JENKINS-10615 [ JENKINS-10615 ]
            brian Brian Murrell added a comment -

            I don't seem to be running into this issue any more.

            brian Brian Murrell made changes -
            Status Open [ 1 ] Resolved [ 5 ]
            Resolution Cannot Reproduce [ 5 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 140138 ] JNJira + In-Review [ 188865 ]

              People

              • Assignee:
                Unassigned
                Reporter:
                brian Brian Murrell
              • Votes:
                1 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: