Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-9999

Installing Plugins/Upgrades causes a java.io.IOException: Server returned HTTP response code: 500 for URL: http://updates.jenkins-ci.org/download/plugins/analysis-core/1.22/analysis-core.hpi

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: core
    • Labels:
      None
    • Environment:
      Linux RedHat
    • Similar Issues:

      Description

      When I attempt to upgrade the plugins from the GUI:
      "Manage Jenkins" -> "Manage Plugins" -> "Updates Tab" -> "Check the box next to any plugin" -> "Click Install"
      I get that following error msg.
      java.io.IOException: Server returned HTTP response code: 500 for URL: http://updates.jenkins-ci.org/download/plugins/jobConfigHistory/1.11/jobConfigHistory.hpi

      When I log into the server and run the following CLI wget command it works and downloads the plug in.
      "wget -d --proxy-user=svc_abeadm --proxy-password=XXXXX http://updates.jenkins-ci.org/download/plugins/pmd/3.17/pmd.hpi"

      In "Manage Jenkins" -> "Manage Plugins" -> "Advanced Tab"
      I have the proxy settings set to the same settings I have set for the proxy on the linux server.

      This is really causing a lot of pain and headache and we are now less and less inclined to upgrade to the latest version of Jenkins because that means we have to manually update 30+ plugins.

      I appreciate your time and helps,

      Kenan

        Attachments

          Activity

          danielbeck Daniel Beck added a comment -

          This was probably a transient issue with the mirrors used to distribute the files. (Recent Jenkins versions now show the mirror URL so you can actually investigate in a useful way, because your wget may well have gotten a different mirror)


            People

            • Assignee:
              Unassigned
              Reporter:
              kenanalkadi kenan alkadi
            • Votes:
              1 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: