Details

    • Type: Task
    • Status: Done (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: design
    • Labels:
      None
    • Similar Issues:

      Description

      As you can see in the screenshot below, our posts appear to be lacking the metadata necessary to make social sites like Twitter & Facebook pick up default images. The screenshot below has two posts, one with image and the other without image.

      I think this is an easy addition that improves the engagement.

        Attachments

          Issue Links

            Activity

            kohsuke Kohsuke Kawaguchi added a comment -

            Screenshot of a link that does this properly:

            rtyler R. Tyler Croy added a comment -

            What you're referring to are "twitter cards"

            And I do not believe this is an "easy addition", I suggest spending more time with our website tooling before making such judgements.

            bitwiseman Liam Newman added a comment - - edited

             

            It looks like some attempt was made to get this working: https://github.com/jenkins-infra/jenkins.io/blob/master/content/_layouts/frame.html.haml#L21

            The twitter card validator says it is working, but it looks like it isn't figuring out an image to use.   

            Maybe this is something I can work on at the hack fest in Nice.

            Twitter card documentation:

            https://developer.twitter.com/en/docs/tweets/optimize-with-cards/overview/abouts-cards.html

            Some related links:

            https://cards-dev.twitter.com/validator 

            https://developer.twitter.com/en/docs/tweets/optimize-with-cards/guides/troubleshooting-cards.html 

            https://blog.twitter.com/developer/en_us/a/2012/twitter-cards-tips-tricks.html

             

            zbynek Zbynek Konecny added a comment -

            For (some) SIGs and projects this was addressed in
            https://github.com/jenkins-infra/jenkins.io/pull/2263
            What's still missing is a fallback and documentation (so that blog authors can use this)

            zbynek Zbynek Konecny added a comment -

            This is duplicate of WEBSITE-520, now DONE


              People

              • Assignee:
                Unassigned
                Reporter:
                kohsuke Kohsuke Kawaguchi
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: