Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-10025

Calling rebuildDependencyGraph() in cycle

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: ivy-plugin
    • Labels:
      None
    • Similar Issues:

      Description

      There probably possible cycle call of rebuildDependencyGraph(),
      Ivy calls
      Hudson.getInstance().rebuildDependencyGraph();
      which starts following cycle:
      getModuleDescriptor() -> recomputeModuleDescriptor() -> setModuleDescriptor() -> hudson.model.Hudson.rebuildDependencyGraph()
      which results into StackOverflowError, for whole exception, see
      http://groups.google.com/group/jenkinsci-users/browse_thread/thread/3c6b67b448c98379#

        Attachments

          Activity

          eguess74 eguess74 added a comment -

          ping!

          eguess74 eguess74 added a comment -

          reassigned back abayer, as there is no response from Gregory

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Nicolas De Loof
          Path:
          src/main/java/hudson/ivy/IvyBuildTrigger.java
          http://jenkins-ci.org/commit/ivy-plugin/6d2408bd3ad92683176908c75d51f3474e69bed2
          Log:
          JENKINS-10025 break cycle computing dependencygraph

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Johno Crawford
          Path:
          src/main/java/hudson/ivy/IvyBuildTrigger.java
          http://jenkins-ci.org/commit/ivy-plugin/54901085f206d0890f59d8b880744e9c3216180c
          Log:
          Merge pull request #6 from ndeloof/master

          JENKINS-10025

          Compare: https://github.com/jenkinsci/ivy-plugin/compare/ce005a0da58c...54901085f206

          eguess74 eguess74 added a comment -

          tested the latest master branch - the problem is gone!

          Thanks everybody!


            People

            • Assignee:
              abayer Andrew Bayer
              Reporter:
              vjuranek vjuranek
            • Votes:
              3 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: