Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-10241

Filenames with & end up in changelog.xml resulting in invalid XML

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: cvs-plugin
    • Labels:
      None
    • Environment:
      jenkins 1.419, linux, java 1.6, cvs
    • Similar Issues:

      Description

      We have a cvs project that contains an "&" sign in a filename, which works for the most part (still not a good idea).

      However, the changelog.xml that is generated contains the plain filename which makes the xml invalid:

      <file>
      <name>Architektur&DesignV1.8.1.doc</name>
      <fullName>/Architektur&DesignV1.8.1.doc</fullName>
      <revision>1.3</revision>
      <dead />
      </file>

      the resulting error in catalina.out is

      Caused by: org.xml.sax.SAXParseException: The reference to entity "DesignV1.8.1.doc" must end with the ';' delimiter.

        Attachments

          Activity

          mindless Alan Harder added a comment -

          changelog-history plugin simply copies these files, it does not create them.. reassigning to core.

          alexlehm Alex Lehmann added a comment - - edited

          I have to do some more tests, maybe this is an issue in the cvs plugin.

          alexlehm Alex Lehmann added a comment -

          it turns out that the problem comes from the cvs plugin which writes xml-files directly.


            People

            • Assignee:
              alexlehm Alex Lehmann
              Reporter:
              alexlehm Alex Lehmann
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: