Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-10897

Publish JUnit test result report fails for slaves running within IBM JDK

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Environment:
    • Similar Issues:

      Description

      Build and Tests were ok, but collecting the test results then failed:

      Recording test results
      ERROR: Failed to archive test reports
      hudson.util.IOException2: remote file operation failed: /RDS/HUDSON/workspace/GIX_Trunk_Build_Daily/label/aixrds4c at hudson.remoting.Channel@57cd75c2:aixrds4c
      	at hudson.FilePath.act(FilePath.java:754)
      	at hudson.FilePath.act(FilePath.java:740)
      	at hudson.tasks.junit.JUnitParser.parse(JUnitParser.java:83)
      	at hudson.tasks.junit.JUnitResultArchiver.parse(JUnitResultArchiver.java:123)
      	at hudson.tasks.junit.JUnitResultArchiver.perform(JUnitResultArchiver.java:135)
      	at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:19)
      	at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:682)
      	at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:657)
      	at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:635)
      	at hudson.model.Build$RunnerImpl.post2(Build.java:161)
      	at hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:604)
      	at hudson.model.Run.run(Run.java:1400)
      	at hudson.matrix.MatrixRun.run(MatrixRun.java:146)
      	at hudson.model.ResourceController.execute(ResourceController.java:88)
      	at hudson.model.Executor.run(Executor.java:175)
      Caused by: java.io.InvalidClassException: hudson.util.io.ParserConfigurator$1; local class incompatible: stream classdesc serialVersionUID = 6472613931861772577, local class serialVersionUID = -2178106894481500733
      	at java.io.ObjectStreamClass.initNonProxy(ObjectStreamClass.java:562)
      	at java.io.ObjectInputStream.readNonProxyDesc(ObjectInputStream.java:1582)
      	at java.io.ObjectInputStream.readClassDesc(ObjectInputStream.java:1495)
      	at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1731)
      	at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1328)
      	at java.io.ObjectInputStream.readObject(ObjectInputStream.java:350)
      	at hudson.remoting.UserRequest.deserialize(UserRequest.java:182)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:98)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:48)
      	at hudson.remoting.Request$2.run(Request.java:287)
      	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
      	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:138)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      	at java.lang.Thread.run(Thread.java:662)
      Build step 'Publish JUnit test result report' changed build result to FAILURE
      

        Attachments

          Issue Links

            Activity

            makr Matthias Kraft added a comment -

            Might be related to JENKINS-10771 and JENKINS-10772...

            makr Matthias Kraft added a comment -

            I just tried with the more recent JDKs:

            • IBM J9 VM (build 2.4, JRE 1.6.0 IBM J9 2.4 AIX ppc64-64 jvmap6460sr9-20110624_85526 (JIT enabled, AOT enabled)
            • IBM J9 VM (build 2.4, JRE 1.6.0 IBM J9 2.4 Linux s390x-64 jvmxz6460sr9-20110624_85526 (JIT enabled, AOT enabled)

            ... but to no avail.

            makr Matthias Kraft added a comment -

            Need to upgrade my JIRA-search-foo.


              People

              • Assignee:
                Unassigned
                Reporter:
                makr Matthias Kraft
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: