Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-1097

Problem with ClearCase plugin with JIRA plugin

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: plugin-proposals
    • Labels:
      None
    • Environment:
      Platform: PC, OS: Windows XP
    • Similar Issues:

      Attachments

        Activity

        redsolo redsolo added a comment -

        I did some investigation why this issue occurred. I could reproduce the issue
        with the Jira plugin and the sample changelog.xml. I found that comments with a
        "(TMS-xxxx)" in them would produce the same problem as Vim saw. If no comments
        had that text in them, the error did not show up. My guess is that Jira should
        annotate those comments.

        The exception that Vim saw was:
        Caused by: java.lang.NullPointerException
        at java.util.Collections$UnmodifiableCollection.<init>(Collections.java :994)
        at java.util.Collections$UnmodifiableSet.<init>(Collections.java:1065)
        at java.util.Collections.unmodifiableSet(Collections.java:1055)
        at hudson.plugins.jira.JiraSite.getProjectKeys(JiraSite.java :128)
        at hudson.plugins.jira.JiraSite.existsIssue(JiraSite.java:175)
        at
        hudson.plugins.jira.JiraChangeLogAnnotator.annotate(JiraChangeLogAnnotator.java:28)
        at hudson.scm.ChangeLogSet$Entry.getMsgAnnotated (ChangeLogSet.java:117)

        Which occurs in the
        http://fisheye5.cenqua.com/browse/hudson/hudson/plugins/jira/src/main/java/hudson/plugins/jira/JiraSite.java?r=1.7#l128
        file. The exception is thrown because the field JiraSite.projects is null, and
        in the method the JiraSite.projects field should be set up properly if it is
        null. The field JiraSite.projects is only set in the JiraSite.setProjectKeys()
        method, perhaps it is not called?

        From my pov, I dont think the problem is caused of the Clear case plugin. The CC
        comment only triggers the Jira annotation who is not set up properly, and thus
        the null ref exception is thrown. But I may be wrong here, so we need some help
        in investigating this.

        kohsuke Kohsuke Kawaguchi added a comment -

        Fixed in JIRA plugin 1.9. Reclassifying to the 'plugin' category as this is not
        a clearcase issue.


          People

          • Assignee:
            redsolo redsolo
            Reporter:
            fester fester
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: