Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-11279

Ivy plugin blocks jenkins startup (hudson/plugins/nant/NantBuilder$NantInstallation)

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: ivy-plugin
    • Labels:
      None
    • Environment:
      OS: Win XP, Win7
      Occurs when trying to start Jenkins 1.432+. When starting the old 1.432 war, startup works fine.
    • Similar Issues:

      Description

      On jenkins startup, the Ivy plugin causes the following Error, which terminates the entire jenkins startup process. Seems Ivy somehow refers the hudson/plugins/nant/NantBuilder class. But I have no jenkins Nant plugin, nor the need for it.

      10-okt-2011 16:21:30 jenkins.model.Jenkins$6 onAttained
      INFO: Loaded all jobs
      10-okt-2011 16:22:30 hudson.ExtensionFinder$Sezpoz find
      WARNING: Failed to load hudson.ExtensionFinder$GuiceFinder
      java.lang.InstantiationException: com.google.inject.internal.util.$ComputationException: com.google.inject.internal.util.$ComputationException: java.lang.NoClassDefFoundError: [Lhudson/plugins/nant/NantBuilder$NantInstallation;
      at net.java.sezpoz.IndexItem.instance(IndexItem.java:191)
      at hudson.ExtensionFinder$Sezpoz.find(ExtensionFinder.java:399)
      etc...
      ...
      Caused by: java.lang.ClassNotFoundException: hudson.plugins.nant.NantBuilder$NantInstallation
      at java.net.URLClassLoader$1.run(Unknown Source)
      etc...
      ...
      10-okt-2011 16:22:32 jenkins.model.Jenkins$6 onTaskFailed
      SEVERE: Failed NullIdDescriptorMonitor.verifyId
      java.lang.Error: java.lang.reflect.InvocationTargetException
      at hudson.init.InitializerFinder.invoke(InitializerFinder.java:114)
      at hudson.init.InitializerFinder$TaskImpl.run(InitializerFinder.java:174)
      at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
      at jenkins.model.Jenkins$5.runTask(Jenkins.java:798)
      at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
      at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      at java.lang.Thread.run(Unknown Source)
      Caused by: java.lang.reflect.InvocationTargetException
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at hudson.init.InitializerFinder.invoke(InitializerFinder.java:110)
      ... 8 more
      Caused by: java.lang.NullPointerException
      at hudson.diagnosis.NullIdDescriptorMonitor.verifyId(NullIdDescriptorMonitor.java:86)
      ... 13 more
      10-okt-2011 16:22:32 hudson.WebAppMain$2 run
      SEVERE: Failed to initialize Jenkins

      (I left some parts of the long stacktrace, as it contains some jenkins and google lib internals, and the warning repeated again a few times)

      The only way to get jenkins start up successfully is by deleting the ivy.hpi file...

        Attachments

          Activity

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Kohsuke Kawaguchi
          Path:
          core/src/main/java/hudson/ExtensionFinder.java
          http://jenkins-ci.org/commit/jenkins/ab421b59d2752e3d6eef143c60f9cdc65f52c990
          Log:
          JENKINS-11279 Guice appears to throw RuntimeException sometimes.

          Compare: https://github.com/jenkinsci/jenkins/compare/e4ca9ac...ab421b5

          dogfood dogfood added a comment -

          Integrated in jenkins_main_trunk #1213
          [FIXED JENKINS-11279] more eager scouting
          JENKINS-11279 Guice appears to throw RuntimeException sometimes.

          Kohsuke Kawaguchi : 87f89bc3abd784826283596cf1629b1bf5553f5b
          Files :

          • core/src/main/java/hudson/ExtensionFinder.java
          • changelog.html

          Kohsuke Kawaguchi : ab421b59d2752e3d6eef143c60f9cdc65f52c990
          Files :

          • core/src/main/java/hudson/ExtensionFinder.java
          mark3000 mark 3000 added a comment -

          Hey guys, thanks for the great info. Recently, I encountered this issue (or similar) when upgrading to 1.435. Are there certain plugins I can disable as a workaround? Other suggestions for a workaround?

          I tried to disable (uncheck) the Ivy plugin with no luck.

          Thanks in advance!

          dreamtime Angela Johansson added a comment -

          Hi,

          Could you have a look at JENKINS-11398, too? It has nothing to do with the Ivy plugin or Jenkins not starting up, but it seems to be related since the DashboardView is also an optional plugin dependency for the Cobertura plugin.

          Thank you!

          dorothyvaliga dorothyvaliga added a comment -

          This looks great. I've had several issues where new plugins have stopped my startup. Here's hoping this will cure that in the future!


            People

            • Assignee:
              kohsuke Kohsuke Kawaguchi
              Reporter:
              belpk K P
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: