Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-11295

xUnit boost test messages are displayed under wrong Class name

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Won't Fix
    • Component/s: xunit-plugin
    • Labels:
      None
    • Similar Issues:
      Show 5 results

      Description

      The attached file is a copy of the one attached to JENKINS-11294.

      The BOOST_TEST_MESSAGEs are erroneously displayed under a Class named with the full path of the source code where the message was emitted.

        Attachments

          Activity

          gbois Gregory Boissinot added a comment -

          Same thing as copy issue: please could you give me a plain Junit example of what do you expect?

          alessio Alessio M. added a comment -

          Here the problem is that the boost Message elements translate as follows:

          <testcase classname="basic.Test_Date.d:/jkslave-ib/workspace/pricinglib-win32_msvc9_release/src/basic_test/date/test_date" name="Test_Date_fromString" time="0">
          <system-out>
          [Message] - Testing input string '1988--8-8'
           == [File] - d:/jkslave-ib/workspace/pricinglib-win32_msvc9_release/src/basic_test/date/test_date.cpp
           == [Line] - 366
          ....
          </system-out>
          </testcase>
          

          Afaict removing the file path in the classname attribute above would fix this bug.

          gbois Gregory Boissinot added a comment -

          Unfortunately, we can't fix this issue.


            People

            • Assignee:
              gbois Gregory Boissinot
              Reporter:
              alessio Alessio M.
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: