Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-11381

Subversion Plugin does not support Subversion 1.7

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: subversion-plugin
    • Labels:
      None
    • Similar Issues:
      Show 5 results

      Attachments

      1. subversion.hpi
        4.12 MB
      2. subversion.hpi
        4.12 MB
      3. subversion.hpi
        4.12 MB

        Issue Links

          Activity

          diane_wills Diane Wills added a comment -

          I'm still not able to update Jenkins to use the Subversion Plugin 1.40. I'm using Jenkins 1.466 on Windows Server 2008. I tried manually updating the Subversion files and writing the empty file Subversion.jpi.pinned to $(JENKINS_HOME)/plugins, but that didn't work; the files got overwritten anyways to the old version.

          Since there are no plans to add Subversion 1.40 to Jenkins permanently, can someone help me?

          rvillanu Richard Villanueva added a comment -

          It is not resolved

          rvillanu Richard Villanueva added a comment -

          It is not resolved

          depe Denis Eperonnier added a comment - - edited

          I noticed something strange using Subversion Plugin 1.40, together with Jenkins 1.467.
          Some time after the upgrade from plugin 1.39, there were some errors when trying to update a slave workspace:

          org.tmatesoft.svn.core.SVNException: svn: E175002: REPORT /svn/xxxxxxxxxx/!svn/vcc/default failed
          at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:304)
          at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:289)
          at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:277)
          at org.tmatesoft.svn.core.internal.io.dav.DAVConnection.performHttpRequest(DAVConnection.java:696)
          at org.tmatesoft.svn.core.internal.io.dav.DAVConnection.doReport(DAVConnection.java:328)
          at org.tmatesoft.svn.core.internal.io.dav.DAVRepository.runReport(DAVRepository.java:1289)
          at org.tmatesoft.svn.core.internal.io.dav.DAVRepository.update(DAVRepository.java:837)
          at org.tmatesoft.svn.core.internal.wc16.SVNUpdateClient16.update(SVNUpdateClient16.java:557)
          at org.tmatesoft.svn.core.internal.wc16.SVNUpdateClient16.doUpdate(SVNUpdateClient16.java:414)
          at org.tmatesoft.svn.core.internal.wc16.SVNUpdateClient16.doUpdate(SVNUpdateClient16.java:324)
          at org.tmatesoft.svn.core.internal.wc2.old.SvnOldUpdate.run(SvnOldUpdate.java:27)
          at org.tmatesoft.svn.core.internal.wc2.old.SvnOldUpdate.run(SvnOldUpdate.java:11)
          at org.tmatesoft.svn.core.internal.wc2.SvnOperationRunner.run(SvnOperationRunner.java:20)
          at org.tmatesoft.svn.core.wc2.SvnOperationFactory.run(SvnOperationFactory.java:1221)
          at org.tmatesoft.svn.core.wc2.SvnOperation.run(SvnOperation.java:292)
          at org.tmatesoft.svn.core.wc.SVNUpdateClient.doUpdate(SVNUpdateClient.java:315)
          at org.tmatesoft.svn.core.wc.SVNUpdateClient.doUpdate(SVNUpdateClient.java:295)
          at org.tmatesoft.svn.core.wc.SVNUpdateClient.doUpdate(SVNUpdateClient.java:391)
          at hudson.scm.subversion.UpdateUpdater$TaskImpl.perform(UpdateUpdater.java:136)
          at hudson.scm.subversion.WorkspaceUpdater$UpdateTask.delegateTo(WorkspaceUpdater.java:144)
          at hudson.scm.SubversionSCM$CheckOutTask.perform(SubversionSCM.java:789)
          at hudson.scm.SubversionSCM$CheckOutTask.invoke(SubversionSCM.java:770)
          at hudson.scm.SubversionSCM$CheckOutTask.invoke(SubversionSCM.java:753)
          at hudson.FilePath$FileCallableWrapper.call(FilePath.java:2180)
          at hudson.remoting.UserRequest.perform(UserRequest.java:118)
          at hudson.remoting.UserRequest.perform(UserRequest.java:48)
          at hudson.remoting.Request$2.run(Request.java:287)
          at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)
          at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
          at java.util.concurrent.FutureTask.run(Unknown Source)
          at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
          at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
          at hudson.remoting.Engine$1$1.run(Engine.java:60)
          at java.lang.Thread.run(Unknown Source)
          Caused by: svn: E175002: REPORT /svn/xxxxxxxx/!svn/vcc/default failed
          at org.tmatesoft.svn.core.SVNErrorMessage.create(SVNErrorMessage.java:208)
          at org.tmatesoft.svn.core.SVNErrorMessage.create(SVNErrorMessage.java:154)
          at org.tmatesoft.svn.core.SVNErrorMessage.create(SVNErrorMessage.java:97)
          ... 34 more
          no change for http://xxxxxxxxx since the previous build

          So I checked svn server log, and I could see that my master node uses the latest SVNKit 1.7.4 ("SVN/1.7.4 SVNKit/1.7.4-jenkins-1 (http://svnkit.com/) t20120507_1224"), but one of my slaves is using an older version ("SVN/1.7.0 SVNKit/1.7.0-dev (http://svnkit.com/) rSNAPSHOT"), can this explain my issue?

          edit: I forgot to mention, my svn server is 1.5, and working copy format is configured as 1.5

          kohsuke Kohsuke Kawaguchi added a comment -

          Richard, Denis, if you see issues with Subversion plugin, please open a separate ticket instead of reopening this.

          This ticket was to track the integration of SVNKit 1.7 that brings in Subversion 1.7 compatibility, and that work is completed. In the event that this work introduced issues, please use a separate ticket, so that we can track issues better. Thanks!


            People

            • Assignee:
              kohsuke Kohsuke Kawaguchi
              Reporter:
              soundworker soundworker
            • Votes:
              108 Vote for this issue
              Watchers:
              96 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: