Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-11582

Allow subsequent patchsets to cancel running/pending builds triggered for a change

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      Our tests are long running which means we might have a 15-20 minute turn-around on pre-testing commits in Gerrit.

      In the cases where a developer quickly realizes their error, and submits a patchset 2, while a patchset 1 is already running wastes a lot of Jenkins slave resources.

      Ideally when I upload Change 13, patchset 2, all pending or running jobs triggered off of Change 13, patchset 1, should be cancelled.

        Attachments

          Activity

          rsandell rsandell added a comment -

          There is a pull request for this in the works https://github.com/jenkinsci/gerrit-trigger-plugin/pull/5
          Just waiting for some broken unit tests to be fixed before pulling it in.

          rsandell rsandell added a comment -

          Experimental fix released in Gerrit Trigger 2.4.0, but it is not working fully as intended, JENKINS-12152 could have something to do with it. But I need help in debugging this.

          t_westling Tomas Westling added a comment -

          commit 6e9bfee152a01c8a012fba0c54e4990e746b0c2b
          Released in 2.6.0


            People

            • Assignee:
              rsandell rsandell
              Reporter:
              rtyler R. Tyler Croy
            • Votes:
              1 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: