Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-11841

Exception after artifacts deployment

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Environment:
      * Jenkins ver. 1.440
    • Similar Issues:

      Description

      Just after deployment artifact the exception is throwen.

      [INFO] Deployment done in 0.78 sec
      FATAL: Comparison method violates its general contract!
      java.lang.IllegalArgumentException: Comparison method violates its general contract!
      at java.util.TimSort.mergeHi(TimSort.java:868)
      at java.util.TimSort.mergeAt(TimSort.java:485)
      at java.util.TimSort.mergeCollapse(TimSort.java:410)
      at java.util.TimSort.sort(TimSort.java:214)
      at java.util.TimSort.sort(TimSort.java:173)
      at java.util.Arrays.sort(Arrays.java:659)
      at java.util.Collections.sort(Collections.java:217)
      at hudson.tasks.BuildTrigger.execute(BuildTrigger.java:198)
      at hudson.model.AbstractBuild$AbstractRunner.cleanUp(AbstractBuild.java:632)
      at hudson.maven.MavenModuleSetBuild$RunnerImpl.cleanUp(MavenModuleSetBuild.java:1015)
      at hudson.model.Run.run(Run.java:1448)
      at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:478)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:230)

        Attachments

          Issue Links

            Activity

            evernat evernat added a comment -

            Given the stack-trace, you have used Java 7 to run Jenkins. (The sort algorithm in Arrays.sort was changed in Java 7.)

            Is the issue reproduced with a recent version of Jenkins?

            lore84 Jakub Štiller added a comment -

            I think it is no longer an issue, we did not see this problem a long time.

            rakeshjain rakesh jain added a comment -

            I am having the same issue. I am using jenkins version 1.512 with java 1.7.0_21. It does not happen for all projects but for few. Can someone shed some light on this?
            Thanks.

            evernat evernat added a comment -

            @rakesh
            Can you give the stack-trace of your exception?
            It is probably a bit different and it is needed to fix the problem.

            rakeshjain rakesh jain added a comment -

            Hi evernat,
            Here it is..Note this happens at the end of the build and so it cant trigger downstream builds.

            [INFO] ------------------------------------------------------------------------
            [INFO] BUILD SUCCESS
            [INFO] ------------------------------------------------------------------------
            [INFO] Total time: 21.444s
            [INFO] Finished at: Wed May 22 16:47:59 EDT 2013
            [INFO] Final Memory: 9M/240M
            [INFO] ------------------------------------------------------------------------
            [JENKINS] Archiving /bbnms/jenkins/R1310/jenkins/workspace/lightspeed-pom/lightspeed-pom/pom.xml to /bbnms/jenkins/R1310/jenkins/jobs/lightspeed-pom/modules/com.att.bbnms.lightspeed$lightspeed-pom/builds/2013-05-22_16-47-33/archive/com.att.bbnms.lightspeed/lightspeed-pom/1310-SNAPSHOT/lightspeed-pom-1310-SNAPSHOT.pom
            Waiting for Jenkins to finish collecting data
            channel stopped
            FATAL: Comparison method violates its general contract!
            java.lang.IllegalArgumentException: Comparison method violates its general contract!
            at java.util.TimSort.mergeHi(TimSort.java:868)
            at java.util.TimSort.mergeAt(TimSort.java:485)
            at java.util.TimSort.mergeForceCollapse(TimSort.java:426)
            at java.util.TimSort.sort(TimSort.java:223)
            at java.util.TimSort.sort(TimSort.java:173)
            at java.util.Arrays.sort(Arrays.java:659)
            at java.util.Collections.sort(Collections.java:217)
            at hudson.tasks.BuildTrigger.execute(BuildTrigger.java:199)
            at hudson.model.AbstractBuild$AbstractBuildExecution.cleanUp(AbstractBuild.java:739)
            at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.cleanUp(MavenModuleSetBuild.java:975)
            at hudson.model.Run.execute(Run.java:1620)
            at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:477)
            at hudson.model.ResourceController.execute(ResourceController.java:88)
            at hudson.model.Executor.run(Executor.java:237)

            evernat evernat added a comment -

            ok, it's probably a regression in recent Jenkins which gives almost the same exception when using Java 7, so reopening the issue.

            The problem is in the sort of downstream dependencies of a job:
            https://github.com/jenkinsci/jenkins/blob/master/core/src/main/java/hudson/tasks/BuildTrigger.java#L199

            But I don't know what has caused this and how to fix it.

            danielbeck Daniel Beck added a comment -

            Looks like a duplicate of JENKINS-17247


              People

              • Assignee:
                Unassigned
                Reporter:
                lore84 Jakub Štiller
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: