Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-11888

Jenkins CLI does not supports stopping jobs

    Details

    • Type: New Feature
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: cli, core
    • Labels:
    • Environment:
      Jenkins CLI does not supports stopping jobs
    • Similar Issues:
    • Released As:
      Jenkins 2.167

      Description

      Please add support of cancel job execution via Jenkins CLI. Something like
      $ java -jar jenkins-cli.jar -s http://[server]:8080/ stop [job name]

        Attachments

          Activity

          corneil_duplessis Corneil du Plessis added a comment -

          Calling the command stop-job or cancel-job should make it relatively unambiguous.

          oleg_nenashev Oleg Nenashev added a comment -

          The issue is actual

          danielbeck Daniel Beck added a comment -

          Not a bug.

          kaltokri Rolf Geuenich added a comment -

          I would like to have this feature, too.
          Even if the request is 3 years old it can help to abort jobs with jenkinscli.

          oleg_nenashev Oleg Nenashev added a comment -

          It's pretty trivial to implement, assigned the newbie-friendly label

          oleg_nenashev Oleg Nenashev added a comment -

          Released in 2.176

          Thanks Ilia Zasimov!


            People

            • Assignee:
              austry Ilia Zasimov
              Reporter:
              pxantom Oleksandr Popov
            • Votes:
              6 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: