Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-11948

jenkins-cli can't login to AD enabled server

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Labels:
      None
    • Environment:
      Jenkins ver. 1.443-SNAPSHOT (private-11/30/2011 01:22 GMT-jenkins) - your official CI build
      active directory plugin 1.24-SNAPSHOT (private-11/30/2011 01:58-jenkins) - from your official CI build
    • Similar Issues:

      Description

      When I try to login using the jenkins-cli.jar using the command

      java -jar jenkins-cli.jar -s http://hudson:8080 login --username user@domain1.com

      and pass in a password token(I get the same issue when I use --password as well) I get a failure to login. The stack trace is attached. It throws an error trying to look up the user 'user@domain1.com.second.domain2.co.uk'.
      If I just try to use user instead of use@domain1.com it fails trying to look up the user 'user@second.domain2.co.uk'
      I do have a list of active directory Domain Names set up, comma separated, 'domain1.com,second.domain2.co.uk' so it is falling back to the last name, but it never finds the user, which is located in domain1.com.

        Attachments

          Activity

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Kohsuke Kawaguchi
          Path:
          src/main/java/hudson/plugins/active_directory/ActiveDirectoryUnixAuthenticationProvider.java
          src/main/java/hudson/plugins/active_directory/ActiveDirectoryUserDetail.java
          src/main/java/hudson/plugins/active_directory/MultiCauseBadCredentialsException.java
          http://jenkins-ci.org/commit/active-directory-plugin/b73fbb9e6773214e02e068741b703d2c1fb33e4c
          Log:
          [FIXED JENKINS-11948] report all the causes, not just one.

          kohsuke Kohsuke Kawaguchi added a comment -

          I'm confused. 1.24 isn't released yet. How can you even try it?

          I just pushed the change — do you think you can build the SNAPSHOT and run it for us?

          dogfood dogfood added a comment -

          Integrated in plugins_active-directory #49
          [FIXED JENKINS-11948] report all the causes, not just one.

          Kohsuke Kawaguchi :
          Files :

          • src/main/java/hudson/plugins/active_directory/ActiveDirectoryUnixAuthenticationProvider.java
          • src/main/java/hudson/plugins/active_directory/ActiveDirectoryUserDetail.java
          • src/main/java/hudson/plugins/active_directory/MultiCauseBadCredentialsException.java
          aflat aflat added a comment -

          I still get the same issue listed above, but it lists "information for aflat@domain1.com" instead of just aflat. If I use the username aflat@domain1.com to login, I get "hudson.plugins.active_directory.MultiCauseBadCredentialsException: Either no suc
          h user 'aflat@domain1.com' or incorrect password" but I can login, using the ui using the same user/pass (aflat/pass, not aflat@domain1.com/pass)

          aflat aflat added a comment -

          And sorry, I said 1.24 when I meant SNAPSHOT, I've just been going by version numbers to keep it clear in my head right now. Been bouncing around versions a bit to see what works.


            People

            • Assignee:
              Unassigned
              Reporter:
              aflat aflat
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: