Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-12195

Any testReport with a # in the name creates broken links

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core
    • Labels:
    • Similar Issues:

      Description

      I have a test suite that generates a test with a name that has a "#" character in it:

      User#update_layout_widgets layout change with invalid widgets

      This causes the URL that is generated by http://example.com/jenkins/job/cxo-gerrit-gelato/2835/testReport/ to be:

      http://example.com/jenkins/job/cxo-gerrit-gelato/2835/testReport/(root)/User#update_layout_widgets%20layout%20change%20with%20too%20many%20columns/User_update_layout_widgets_layout_change_with_too_many_columns_does_not_change_the_layout/

      This is wrong, because the '#' isn't being escaped and testReport/(root)/User returns a 404.

      Obviously whatever is doing the escaping thinks it's an anchor, not part of the name.

        Attachments

          Activity

          evernat evernat added a comment -

          Is it reproduced with recent Jenkins and plugins versions?

          docwhat Christian Höltje added a comment -

          It works for now with versions:

          Jenkins ver. 1.480.1
          xUnit Plugin ver. 1.51

          Thanks!

          docwhat Christian Höltje added a comment -

          Works now.


            People

            • Assignee:
              Unassigned
              Reporter:
              docwhat Christian Höltje
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: