Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-12280

Warnings plugin does strange things with a custom parser

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: warnings-plugin
    • Labels:
      None
    • Environment:
      Linux master, Windows slave.
      Jenkins 1.441, Warnings 3.24.
    • Similar Issues:

      Description

      I configured a parser in the main Configure section and verified that it would match and report a warning. However, it would only report one even if I copied extra lines?
      During an actual build (on the slave) it is reported to be run. I see the correct parser name (that I gave it), the correct file name of the log file, and it claims to have found 4 warnings ("Successfully parsed ... with 4 warnings").

      The problems are:

      • There should, by my count, be 18 warnings
      • It doesn't actually report warnings from the parser in the "Warnings" result

      There is one other warning parser involved, an MSBuild parser. There are 2 warnings from that (correct), and I also get 2 warnings from the not configured "PC-Lint" parser. The alleged PC-Lint warnings are identical to the MSBuild warnings, apart from the type.
      No warnings are reported for my parser.

      It could look like there's some mix-up of parsers? Is this by any chance related to JENKINS-11926?

      Further details:

      • Both warnings parsers are run on the same file.
      • The warnings I want to parse do not have file names nor line numbers. I've tried putting both "some text" and "" as file name, and 0 or 1 for line number. Neither worked any differently.

        Attachments

          Issue Links

            Activity

            dogfood dogfood added a comment -

            Integrated in plugins_warnings #350
            [FIXED JENKINS-12280] [FIXED JENKINS-11926] Make GroovyExpressionMatcher (Revision a39922f468a93eeaef749034ee42aede81ad7088)

            Result = SUCCESS
            Ulli Hafner :
            Files :

            • src/main/java/hudson/plugins/warnings/parser/GroovyExpressionMatcher.java
            drulli Ulli Hafner added a comment -

            Fixed in 3.27.

            drulli Ulli Hafner added a comment -

            @torbent: is release 3.27 fixing the problem for you? Seems that JENKINS-11926 is reopened.

            torbent torbent added a comment -

            Sorry about the delay.
            Just checked. Running Jenkins 1.445 and Warnings plugin 3.27 on a test-ish setup.
            Both master and slave are Linux-based.
            I get all the warnings I expect, so it seems to be working for me
            Now I'll take it into our production environment and check it. It has a Linux server and both Linux and Windows based slaves. I'll get back tomorrow with the results of that test.

            torbent torbent added a comment -

            Closing. Confirmed to work in production setup as well (Linux master, Windows slave).


              People

              • Assignee:
                drulli Ulli Hafner
                Reporter:
                torbent torbent
              • Votes:
                1 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: