Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-12334

jenkins does not start in jboss container

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: core
    • Labels:
    • Environment:
      JBoss 5.1 EAP

      Description

      Using latest RC version of jenkins, starting jboss up gives these errors:

      2012-01-09 16:07:06,859 INFO [org.jboss.bootstrap.microcontainer.ServerImpl] (main) JBoss (Microcontainer) [5.1.0 (build: SVNTag=JBPAPP_5_1_0 date=201009150028)] Started in 32s:316ms
      2012-01-09 16:07:07,305 INFO [jenkins.InitReactorRunner] (pool-14-thread-2) Started initialization
      2012-01-09 16:07:09,553 INFO [jenkins.InitReactorRunner] (pool-14-thread-4) Listed all plugins
      2012-01-09 16:07:13,601 INFO [jenkins.InitReactorRunner] (pool-14-thread-2) Prepared all plugins
      2012-01-09 16:07:18,630 ERROR [STDERR] (Initializing plugin copyartifact) SLF4J: slf4j-api 1.6.x (or later) is incompatible with this binding.
      2012-01-09 16:07:18,630 ERROR [STDERR] (Initializing plugin copyartifact) SLF4J: Your binding is version 1.5.5 or earlier.
      2012-01-09 16:07:18,630 ERROR [STDERR] (Initializing plugin copyartifact) SLF4J: Upgrade your binding to version 1.6.x. or 2.0.x
      2012-01-09 16:07:18,637 WARNING [hudson.ExtensionFinder$GuiceFinder] (Initializing plugin copyartifact) Failed to instantiate. Skipping this component
      com.google.inject.ProvisionException: Guice provision errors:

      1) Error injecting constructor, java.lang.NoSuchMethodError: org.slf4j.impl.StaticLoggerBinder.getSingleton()Lorg/slf4j/impl/StaticLoggerBinder;
      at org.jenkinsci.main.modules.sshd.SSHD.<init>(SSHD.java:40)

      1 error
      at com.google.inject.internal.ProviderToInternalFactoryAdapter.get(ProviderToInternalFactoryAdapter.java:52)
      at com.google.inject.Scopes$1$1.get(Scopes.java:59)
      at hudson.ExtensionFinder$AbstractGuiceFinder$2$1.get(ExtensionFinder.java:365)
      at com.google.inject.internal.InternalFactoryToProviderAdapter.get(InternalFactoryToProviderAdapter.java:41)
      at com.google.inject.internal.SingleFieldInjector.inject(SingleFieldInjector.java:54)
      at com.google.inject.internal.MembersInjectorImpl.injectMembers(MembersInjectorImpl.java:118)
      at com.google.inject.internal.ConstructorInjector.provision(ConstructorInjector.java:117)
      at com.google.inject.internal.ConstructorInjector.construct(ConstructorInjector.java:87)
      at com.google.inject.internal.ConstructorBindingImpl$Factory.get(ConstructorBindingImpl.java:259)
      at com.google.inject.internal.ProviderToInternalFactoryAdapter$1.call(ProviderToInternalFactoryAdapter.java:46)
      at com.google.inject.internal.InjectorImpl.callInContext(InjectorImpl.java:1018)
      at com.google.inject.internal.ProviderToInternalFactoryAdapter.get(ProviderToInternalFactoryAdapter.java:40)
      at com.google.inject.Scopes$1$1.get(Scopes.java:59)
      at hudson.ExtensionFinder$AbstractGuiceFinder$2$1.get(ExtensionFinder.java:365)
      at com.google.inject.internal.InternalFactoryToProviderAdapter.get(InternalFactoryToProviderAdapter.java:41)
      at com.google.inject.internal.InjectorImpl$3$1.call(InjectorImpl.java:965)
      at com.google.inject.internal.InjectorImpl.callInContext(InjectorImpl.java:1011)
      at com.google.inject.internal.InjectorImpl$3.get(InjectorImpl.java:961)
      at hudson.ExtensionFinder$AbstractGuiceFinder._find(ExtensionFinder.java:336)
      at hudson.ExtensionFinder$AbstractGuiceFinder.find(ExtensionFinder.java:327)
      at hudson.ExtensionFinder._find(ExtensionFinder.java:147)
      at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:289)
      at hudson.ExtensionList.load(ExtensionList.java:278)
      at hudson.ExtensionList.ensureLoaded(ExtensionList.java:231)
      at hudson.ExtensionList.iterator(ExtensionList.java:138)
      at jenkins.model.Jenkins.getDescriptorByType(Jenkins.java:1046)
      at hudson.plugins.copyartifact.BuildSelectorParameter.initAliases(BuildSelectorParameter.java:100)
      at hudson.plugins.copyartifact.CopyArtifactPlugin.postInitialize(CopyArtifactPlugin.java:35)
      at hudson.PluginManager$2$1$2.run(PluginManager.java:310)
      at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:146)
      at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
      at jenkins.model.Jenkins$5.runTask(Jenkins.java:800)
      at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
      at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      at java.lang.Thread.run(Thread.java:662)
      Caused by: java.lang.NoSuchMethodError: org.slf4j.impl.StaticLoggerBinder.getSingleton()Lorg/slf4j/impl/StaticLoggerBinder;
      at org.slf4j.LoggerFactory.bind(LoggerFactory.java:121)
      at org.slf4j.LoggerFactory.performInitialization(LoggerFactory.java:111)
      at org.slf4j.LoggerFactory.getILoggerFactory(LoggerFactory.java:268)
      at org.slf4j.LoggerFactory.getLogger(LoggerFactory.java:241)
      at org.slf4j.LoggerFactory.getLogger(LoggerFactory.java:254)
      at org.apache.sshd.common.AbstractFactoryManager.<init>(AbstractFactoryManager.java:37)
      at org.apache.sshd.SshServer.<init>(SshServer.java:140)
      at org.apache.sshd.SshServer.setUpDefaultServer(SshServer.java:428)
      at org.jenkinsci.main.modules.sshd.SSHD.<init>(SSHD.java:33)
      at org.jenkinsci.main.modules.sshd.SSHD$$FastClassByGuice$$c0b3a86e.newInstance(<generated>)
      at com.google.inject.internal.cglib.reflect.$FastConstructor.newInstance(FastConstructor.java:40)
      at com.google.inject.internal.DefaultConstructionProxyFactory$1.newInstance(DefaultConstructionProxyFactory.java:61)
      at com.google.inject.internal.ConstructorInjector.provision(ConstructorInjector.java:108)
      at com.google.inject.internal.ConstructorInjector.construct(ConstructorInjector.java:87)
      at com.google.inject.internal.ConstructorBindingImpl$Factory.get(ConstructorBindingImpl.java:259)
      at com.google.inject.internal.ProviderToInternalFactoryAdapter$1.call(ProviderToInternalFactoryAdapter.java:46)
      at com.google.inject.internal.InjectorImpl.callInContext(InjectorImpl.java:1018)
      at com.google.inject.internal.ProviderToInternalFactoryAdapter.get(ProviderToInternalFactoryAdapter.java:40)
      ... 36 more
      2012-01-09 16:07:18,639 WARNING [hudson.ExtensionFinder$GuiceFinder] (Initializing plugin copyartifact) Failed to instantiate. Skipping this component
      com.google.inject.ProvisionException: Guice provision errors:

      1) null returned by binding at hudson.ExtensionFinder$AbstractGuiceFinder$SezpozModule.configure(ExtensionFinder.java:432)
      but org.jenkinsci.main.modules.sshd.PortAdvertiser.sshd is not @Nullable
      while locating org.jenkinsci.main.modules.sshd.SSHD
      for field at org.jenkinsci.main.modules.sshd.PortAdvertiser.sshd(PortAdvertiser.java:18)

      1 error
      at com.google.inject.internal.ProviderToInternalFactoryAdapter.get(ProviderToInternalFactoryAdapter.java:52)
      at com.google.inject.Scopes$1$1.get(Scopes.java:59)
      at hudson.ExtensionFinder$AbstractGuiceFinder$2$1.get(ExtensionFinder.java:365)
      at com.google.inject.internal.InternalFactoryToProviderAdapter.get(InternalFactoryToProviderAdapter.java:41)
      at com.google.inject.internal.InjectorImpl$3$1.call(InjectorImpl.java:965)
      at com.google.inject.internal.InjectorImpl.callInContext(InjectorImpl.java:1011)
      at com.google.inject.internal.InjectorImpl$3.get(InjectorImpl.java:961)
      at hudson.ExtensionFinder$AbstractGuiceFinder._find(ExtensionFinder.java:336)
      at hudson.ExtensionFinder$AbstractGuiceFinder.find(ExtensionFinder.java:327)
      at hudson.ExtensionFinder._find(ExtensionFinder.java:147)
      at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:289)
      at hudson.ExtensionList.load(ExtensionList.java:278)
      at hudson.ExtensionList.ensureLoaded(ExtensionList.java:231)
      at hudson.ExtensionList.iterator(ExtensionList.java:138)
      at jenkins.model.Jenkins.getDescriptorByType(Jenkins.java:1046)
      at hudson.plugins.copyartifact.BuildSelectorParameter.initAliases(BuildSelectorParameter.java:100)
      at hudson.plugins.copyartifact.CopyArtifactPlugin.postInitialize(CopyArtifactPlugin.java:35)
      at hudson.PluginManager$2$1$2.run(PluginManager.java:310)
      at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:146)
      at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
      at jenkins.model.Jenkins$5.runTask(Jenkins.java:800)
      at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
      at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      at java.lang.Thread.run(Thread.java:662)
      2012-01-09 16:07:18,640 WARNING [hudson.ExtensionFinder$GuiceFinder] (Initializing plugin copyartifact) Failed to instantiate. Skipping this component
      com.google.inject.ProvisionException: Guice provision errors:

      1) Error injecting constructor, java.lang.IllegalStateException: org.slf4j.LoggerFactory could not be successfully initialized. See also http://www.slf4j.org/codes.html#unsuccessfulInit
      at org.jenkinsci.main.modules.sshd.SSHD.<init>(SSHD.java:40)

      1 error
      at com.google.inject.internal.ProviderToInternalFactoryAdapter.get(ProviderToInternalFactoryAdapter.java:52)
      at com.google.inject.Scopes$1$1.get(Scopes.java:59)
      at hudson.ExtensionFinder$AbstractGuiceFinder$2$1.get(ExtensionFinder.java:365)
      at com.google.inject.internal.InternalFactoryToProviderAdapter.get(InternalFactoryToProviderAdapter.java:41)
      at com.google.inject.internal.InjectorImpl$3$1.call(InjectorImpl.java:965)
      at com.google.inject.internal.InjectorImpl.callInContext(InjectorImpl.java:1011)
      at com.google.inject.internal.InjectorImpl$3.get(InjectorImpl.java:961)
      at hudson.ExtensionFinder$AbstractGuiceFinder._find(ExtensionFinder.java:336)
      at hudson.ExtensionFinder$AbstractGuiceFinder.find(ExtensionFinder.java:327)
      at hudson.ExtensionFinder._find(ExtensionFinder.java:147)
      at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:289)
      at hudson.ExtensionList.load(ExtensionList.java:278)
      at hudson.ExtensionList.ensureLoaded(ExtensionList.java:231)
      at hudson.ExtensionList.iterator(ExtensionList.java:138)
      at jenkins.model.Jenkins.getDescriptorByType(Jenkins.java:1046)
      at hudson.plugins.copyartifact.BuildSelectorParameter.initAliases(BuildSelectorParameter.java:100)
      at hudson.plugins.copyartifact.CopyArtifactPlugin.postInitialize(CopyArtifactPlugin.java:35)
      at hudson.PluginManager$2$1$2.run(PluginManager.java:310)
      at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:146)
      at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
      at jenkins.model.Jenkins$5.runTask(Jenkins.java:800)
      at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
      at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      at java.lang.Thread.run(Thread.java:662)
      Caused by: java.lang.IllegalStateException: org.slf4j.LoggerFactory could not be successfully initialized. See also http://www.slf4j.org/codes.html#unsuccessfulInit
      at org.slf4j.LoggerFactory.getILoggerFactory(LoggerFactory.java:277)
      at org.slf4j.LoggerFactory.getLogger(LoggerFactory.java:241)
      at org.slf4j.LoggerFactory.getLogger(LoggerFactory.java:254)
      at org.apache.sshd.common.AbstractFactoryManager.<init>(AbstractFactoryManager.java:37)
      at org.apache.sshd.SshServer.<init>(SshServer.java:140)
      at org.apache.sshd.SshServer.setUpDefaultServer(SshServer.java:428)
      at org.jenkinsci.main.modules.sshd.SSHD.<init>(SSHD.java:33)
      at org.jenkinsci.main.modules.sshd.SSHD$$FastClassByGuice$$c0b3a86e.newInstance(<generated>)
      at com.google.inject.internal.cglib.reflect.$FastConstructor.newInstance(FastConstructor.java:40)
      at com.google.inject.internal.DefaultConstructionProxyFactory$1.newInstance(DefaultConstructionProxyFactory.java:61)
      at com.google.inject.internal.ConstructorInjector.provision(ConstructorInjector.java:108)
      at com.google.inject.internal.ConstructorInjector.construct(ConstructorInjector.java:87)
      at com.google.inject.internal.ConstructorBindingImpl$Factory.get(ConstructorBindingImpl.java:259)
      at com.google.inject.internal.ProviderToInternalFactoryAdapter$1.call(ProviderToInternalFactoryAdapter.java:46)
      at com.google.inject.internal.InjectorImpl.callInContext(InjectorImpl.java:1018)
      at com.google.inject.internal.ProviderToInternalFactoryAdapter.get(ProviderToInternalFactoryAdapter.java:40)
      ... 25 more
      2012-01-09 16:07:19,936 INFO [jenkins.InitReactorRunner] (pool-14-thread-1) Started all plugins
      2012-01-09 16:07:19,936 INFO [jenkins.InitReactorRunner] (pool-14-thread-2) Augmented all extensions
      2012-01-09 16:07:25,090 INFO [jenkins.InitReactorRunner] (pool-14-thread-3) Loaded all jobs
      2012-01-09 16:07:25,094 WARNING [hudson.ExtensionFinder$GuiceFinder] (SSHD.init) Failed to instantiate. Skipping this component
      com.google.inject.ProvisionException: Guice provision errors:

      1) Error injecting constructor, java.lang.IllegalStateException: org.slf4j.LoggerFactory could not be successfully initialized. See also http://www.slf4j.org/codes.html#unsuccessfulInit
      at org.jenkinsci.main.modules.sshd.SSHD.<init>(SSHD.java:40)

      1 error
      at com.google.inject.internal.ProviderToInternalFactoryAdapter.get(ProviderToInternalFactoryAdapter.java:52)
      at com.google.inject.Scopes$1$1.get(Scopes.java:59)
      at hudson.ExtensionFinder$AbstractGuiceFinder$2$1.get(ExtensionFinder.java:365)
      at com.google.inject.internal.InternalFactoryToProviderAdapter.get(InternalFactoryToProviderAdapter.java:41)
      at com.google.inject.internal.InjectorImpl$3$1.call(InjectorImpl.java:965)
      at com.google.inject.internal.InjectorImpl.callInContext(InjectorImpl.java:1011)
      at com.google.inject.internal.InjectorImpl$3.get(InjectorImpl.java:961)
      at hudson.ExtensionFinder$AbstractGuiceFinder._find(ExtensionFinder.java:336)
      at hudson.ExtensionFinder$AbstractGuiceFinder.find(ExtensionFinder.java:327)
      at hudson.ExtensionFinder._find(ExtensionFinder.java:147)
      at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:289)
      at hudson.ExtensionList.load(ExtensionList.java:278)
      at hudson.ExtensionList.ensureLoaded(ExtensionList.java:231)
      at hudson.ExtensionList.iterator(ExtensionList.java:138)
      at hudson.ExtensionList.get(ExtensionList.java:129)
      at org.jenkinsci.main.modules.sshd.SSHD.get(SSHD.java:128)
      at org.jenkinsci.main.modules.sshd.SSHD.init(SSHD.java:133)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at hudson.init.InitializerFinder.invoke(InitializerFinder.java:120)
      at hudson.init.InitializerFinder$TaskImpl.run(InitializerFinder.java:184)
      at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
      at jenkins.model.Jenkins$5.runTask(Jenkins.java:800)
      at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
      at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      at java.lang.Thread.run(Thread.java:662)
      Caused by: java.lang.IllegalStateException: org.slf4j.LoggerFactory could not be successfully initialized. See also http://www.slf4j.org/codes.html#unsuccessfulInit
      at org.slf4j.LoggerFactory.getILoggerFactory(LoggerFactory.java:277)
      at org.slf4j.LoggerFactory.getLogger(LoggerFactory.java:241)
      at org.slf4j.LoggerFactory.getLogger(LoggerFactory.java:254)
      at org.apache.sshd.common.AbstractFactoryManager.<init>(AbstractFactoryManager.java:37)
      at org.apache.sshd.SshServer.<init>(SshServer.java:140)
      at org.apache.sshd.SshServer.setUpDefaultServer(SshServer.java:428)
      at org.jenkinsci.main.modules.sshd.SSHD.<init>(SSHD.java:33)
      at org.jenkinsci.main.modules.sshd.SSHD$$FastClassByGuice$$c0b3a86e.newInstance(<generated>)
      at com.google.inject.internal.cglib.reflect.$FastConstructor.newInstance(FastConstructor.java:40)
      at com.google.inject.internal.DefaultConstructionProxyFactory$1.newInstance(DefaultConstructionProxyFactory.java:61)
      at com.google.inject.internal.ConstructorInjector.provision(ConstructorInjector.java:108)
      at com.google.inject.internal.ConstructorInjector.construct(ConstructorInjector.java:87)
      at com.google.inject.internal.ConstructorBindingImpl$Factory.get(ConstructorBindingImpl.java:259)
      at com.google.inject.internal.ProviderToInternalFactoryAdapter$1.call(ProviderToInternalFactoryAdapter.java:46)
      at com.google.inject.internal.InjectorImpl.callInContext(InjectorImpl.java:1018)
      at com.google.inject.internal.ProviderToInternalFactoryAdapter.get(ProviderToInternalFactoryAdapter.java:40)
      ... 29 more
      2012-01-09 16:07:25,096 SEVERE [jenkins.InitReactorRunner] (pool-14-thread-2) Failed SSHD.init
      java.lang.Error: java.lang.reflect.InvocationTargetException
      at hudson.init.InitializerFinder.invoke(InitializerFinder.java:124)
      at hudson.init.InitializerFinder$TaskImpl.run(InitializerFinder.java:184)
      at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
      at jenkins.model.Jenkins$5.runTask(Jenkins.java:800)
      at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
      at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      at java.lang.Thread.run(Thread.java:662)
      Caused by: java.lang.reflect.InvocationTargetException
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at hudson.init.InitializerFinder.invoke(InitializerFinder.java:120)
      ... 8 more
      Caused by: java.lang.NullPointerException
      at org.jenkinsci.main.modules.sshd.SSHD.init(SSHD.java:133)
      ... 13 more
      2012-01-09 16:07:25,100 SEVERE [hudson.WebAppMain] (hudson initialization thread) Failed to initialize Jenkins
      org.jvnet.hudson.reactor.ReactorException: java.lang.Error: java.lang.reflect.InvocationTargetException
      at org.jvnet.hudson.reactor.Reactor.execute(Reactor.java:246)
      at jenkins.InitReactorRunner.run(InitReactorRunner.java:43)
      at jenkins.model.Jenkins.executeReactor(Jenkins.java:811)
      at jenkins.model.Jenkins.<init>(Jenkins.java:732)
      at hudson.model.Hudson.<init>(Hudson.java:81)
      at hudson.model.Hudson.<init>(Hudson.java:77)
      at hudson.WebAppMain$2.run(WebAppMain.java:217)
      Caused by: java.lang.Error: java.lang.reflect.InvocationTargetException
      at hudson.init.InitializerFinder.invoke(InitializerFinder.java:124)
      at hudson.init.InitializerFinder$TaskImpl.run(InitializerFinder.java:184)
      at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
      at jenkins.model.Jenkins$5.runTask(Jenkins.java:800)
      at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
      at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      at java.lang.Thread.run(Thread.java:662)
      Caused by: java.lang.reflect.InvocationTargetException
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at hudson.init.InitializerFinder.invoke(InitializerFinder.java:120)
      ... 8 more
      Caused by: java.lang.NullPointerException
      at org.jenkinsci.main.modules.sshd.SSHD.init(SSHD.java:133)
      ... 13 more
      2012-01-09 16:07:25,108 WARNING [hudson.ExtensionFinder$GuiceFinder] (hudson initialization thread) Failed to instantiate. Skipping this component
      com.google.inject.ProvisionException: Guice provision errors:

      1) Error injecting constructor, java.lang.IllegalStateException: org.slf4j.LoggerFactory could not be successfully initialized. See also http://www.slf4j.org/codes.html#unsuccessfulInit
      at org.jenkinsci.main.modules.sshd.SSHD.<init>(SSHD.java:40)

      1 error
      at com.google.inject.internal.ProviderToInternalFactoryAdapter.get(ProviderToInternalFactoryAdapter.java:52)
      at com.google.inject.Scopes$1$1.get(Scopes.java:59)
      at hudson.ExtensionFinder$AbstractGuiceFinder$2$1.get(ExtensionFinder.java:365)
      at com.google.inject.internal.InternalFactoryToProviderAdapter.get(InternalFactoryToProviderAdapter.java:41)
      at com.google.inject.internal.SingleFieldInjector.inject(SingleFieldInjector.java:54)
      at com.google.inject.internal.MembersInjectorImpl.injectMembers(MembersInjectorImpl.java:118)
      at com.google.inject.internal.ConstructorInjector.provision(ConstructorInjector.java:117)
      at com.google.inject.internal.ConstructorInjector.construct(ConstructorInjector.java:87)
      at com.google.inject.internal.ConstructorBindingImpl$Factory.get(ConstructorBindingImpl.java:259)
      at com.google.inject.internal.ProviderToInternalFactoryAdapter$1.call(ProviderToInternalFactoryAdapter.java:46)
      at com.google.inject.internal.InjectorImpl.callInContext(InjectorImpl.java:1018)
      at com.google.inject.internal.ProviderToInternalFactoryAdapter.get(ProviderToInternalFactoryAdapter.java:40)
      at com.google.inject.Scopes$1$1.get(Scopes.java:59)
      at hudson.ExtensionFinder$AbstractGuiceFinder$2$1.get(ExtensionFinder.java:365)
      at com.google.inject.internal.InternalFactoryToProviderAdapter.get(InternalFactoryToProviderAdapter.java:41)
      at com.google.inject.internal.InjectorImpl$3$1.call(InjectorImpl.java:965)
      at com.google.inject.internal.InjectorImpl.callInContext(InjectorImpl.java:1011)
      at com.google.inject.internal.InjectorImpl$3.get(InjectorImpl.java:961)
      at hudson.ExtensionFinder$AbstractGuiceFinder._find(ExtensionFinder.java:336)
      at hudson.ExtensionFinder$AbstractGuiceFinder.find(ExtensionFinder.java:327)
      at hudson.ExtensionFinder._find(ExtensionFinder.java:147)
      at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:289)
      at hudson.ExtensionList.load(ExtensionList.java:278)
      at hudson.ExtensionList.ensureLoaded(ExtensionList.java:231)
      at hudson.ExtensionList.iterator(ExtensionList.java:138)
      at jenkins.model.Jenkins.cleanUp(Jenkins.java:2436)
      at hudson.WebAppMain$2.run(WebAppMain.java:242)
      Caused by: java.lang.IllegalStateException: org.slf4j.LoggerFactory could not be successfully initialized. See also http://www.slf4j.org/codes.html#unsuccessfulInit
      at org.slf4j.LoggerFactory.getILoggerFactory(LoggerFactory.java:277)
      at org.slf4j.LoggerFactory.getLogger(LoggerFactory.java:241)
      at org.slf4j.LoggerFactory.getLogger(LoggerFactory.java:254)
      at org.apache.sshd.common.AbstractFactoryManager.<init>(AbstractFactoryManager.java:37)
      at org.apache.sshd.SshServer.<init>(SshServer.java:140)
      at org.apache.sshd.SshServer.setUpDefaultServer(SshServer.java:428)
      at org.jenkinsci.main.modules.sshd.SSHD.<init>(SSHD.java:33)
      at org.jenkinsci.main.modules.sshd.SSHD$$FastClassByGuice$$c0b3a86e.newInstance(<generated>)
      at com.google.inject.internal.cglib.reflect.$FastConstructor.newInstance(FastConstructor.java:40)
      at com.google.inject.internal.DefaultConstructionProxyFactory$1.newInstance(DefaultConstructionProxyFactory.java:61)
      at com.google.inject.internal.ConstructorInjector.provision(ConstructorInjector.java:108)
      at com.google.inject.internal.ConstructorInjector.construct(ConstructorInjector.java:87)
      at com.google.inject.internal.ConstructorBindingImpl$Factory.get(ConstructorBindingImpl.java:259)
      at com.google.inject.internal.ProviderToInternalFactoryAdapter$1.call(ProviderToInternalFactoryAdapter.java:46)
      at com.google.inject.internal.InjectorImpl.callInContext(InjectorImpl.java:1018)
      at com.google.inject.internal.ProviderToInternalFactoryAdapter.get(ProviderToInternalFactoryAdapter.java:40)
      ... 26 more
      2012-01-09 16:07:25,109 WARNING [hudson.ExtensionFinder$GuiceFinder] (hudson initialization thread) Failed to instantiate. Skipping this component
      com.google.inject.ProvisionException: Guice provision errors:

      1) null returned by binding at hudson.ExtensionFinder$AbstractGuiceFinder$SezpozModule.configure(ExtensionFinder.java:432)
      but org.jenkinsci.main.modules.sshd.ItemListenerImpl.sshd is not @Nullable
      while locating org.jenkinsci.main.modules.sshd.SSHD
      for field at org.jenkinsci.main.modules.sshd.ItemListenerImpl.sshd(ItemListenerImpl.java:14)

      1 error
      at com.google.inject.internal.ProviderToInternalFactoryAdapter.get(ProviderToInternalFactoryAdapter.java:52)
      at com.google.inject.Scopes$1$1.get(Scopes.java:59)
      at hudson.ExtensionFinder$AbstractGuiceFinder$2$1.get(ExtensionFinder.java:365)
      at com.google.inject.internal.InternalFactoryToProviderAdapter.get(InternalFactoryToProviderAdapter.java:41)
      at com.google.inject.internal.InjectorImpl$3$1.call(InjectorImpl.java:965)
      at com.google.inject.internal.InjectorImpl.callInContext(InjectorImpl.java:1011)
      at com.google.inject.internal.InjectorImpl$3.get(InjectorImpl.java:961)
      at hudson.ExtensionFinder$AbstractGuiceFinder._find(ExtensionFinder.java:336)
      at hudson.ExtensionFinder$AbstractGuiceFinder.find(ExtensionFinder.java:327)
      at hudson.ExtensionFinder._find(ExtensionFinder.java:147)
      at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:289)
      at hudson.ExtensionList.load(ExtensionList.java:278)
      at hudson.ExtensionList.ensureLoaded(ExtensionList.java:231)
      at hudson.ExtensionList.iterator(ExtensionList.java:138)
      at jenkins.model.Jenkins.cleanUp(Jenkins.java:2436)
      at hudson.WebAppMain$2.run(WebAppMain.java:242)
      2012-01-09 16:07:25,115 INFO [hudson.PluginWrapper] (hudson initialization thread) Stopping ant
      2012-01-09 16:07:25,115 INFO [hudson.PluginWrapper] (hudson initialization thread) Stopping javadoc
      2012-01-09 16:07:25,115 INFO [hudson.PluginWrapper] (hudson initialization thread) Stopping translation
      2012-01-09 16:07:25,115 INFO [hudson.PluginWrapper] (hudson initialization thread) Stopping maven-plugin
      2012-01-09 16:07:25,116 INFO [hudson.PluginWrapper] (hudson initialization thread) Stopping promoted-builds
      2012-01-09 16:07:25,116 INFO [hudson.PluginWrapper] (hudson initialization thread) Stopping active-directory
      2012-01-09 16:07:25,116 INFO [hudson.PluginWrapper] (hudson initialization thread) Stopping copyartifact
      2012-01-09 16:07:25,116 INFO [hudson.PluginWrapper] (hudson initialization thread) Stopping subversion
      2012-01-09 16:07:25,116 INFO [hudson.PluginWrapper] (hudson initialization thread) Stopping WebSVN2
      2012-01-09 16:07:25,116 INFO [hudson.PluginWrapper] (hudson initialization thread) Stopping deploy
      2012-01-09 16:07:25,117 INFO [hudson.PluginWrapper] (hudson initialization thread) Stopping dashboard-view
      2012-01-09 16:07:25,117 INFO [hudson.PluginWrapper] (hudson initialization thread) Stopping cobertura
      2012-01-09 16:07:25,117 INFO [hudson.PluginWrapper] (hudson initialization thread) Stopping sonar
      2012-01-09 16:07:25,117 INFO [hudson.PluginWrapper] (hudson initialization thread) Stopping artifactdeployer
      2012-01-09 16:07:25,117 INFO [hudson.PluginWrapper] (hudson initialization thread) Stopping cvs
      2012-01-09 16:07:25,117 INFO [hudson.PluginWrapper] (hudson initialization thread) Stopping violations
      2012-01-09 16:07:25,118 INFO [hudson.PluginWrapper] (hudson initialization thread) Stopping audit-trail
      2012-01-09 16:07:25,118 INFO [hudson.PluginWrapper] (hudson initialization thread) Stopping disk-usage
      2012-01-09 16:07:25,118 INFO [hudson.PluginWrapper] (hudson initialization thread) Stopping release
      2012-01-09 16:07:25,119 INFO [hudson.PluginWrapper] (hudson initialization thread) Stopping publish-over-ssh
      2012-01-09 16:07:25,119 INFO [hudson.PluginWrapper] (hudson initialization thread) Stopping m2release
      2012-01-09 16:07:25,120 INFO [hudson.PluginWrapper] (hudson initialization thread) Stopping performance
      2012-01-09 16:07:25,121 INFO [hudson.PluginWrapper] (hudson initialization thread) Stopping ssh-slaves
      2012-01-09 16:07:25,118 ERROR [STDERR] (pool-14-thread-4) Exception in thread "pool-14-thread-4"
      2012-01-09 16:07:25,121 ERROR [STDERR] (pool-14-thread-4) java.lang.NullPointerException
      2012-01-09 16:07:25,121 ERROR [STDERR] (pool-14-thread-4) at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:191)
      2012-01-09 16:07:25,121 ERROR [STDERR] (pool-14-thread-4) at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
      2012-01-09 16:07:25,121 ERROR [STDERR] (pool-14-thread-4) at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      2012-01-09 16:07:25,121 ERROR [STDERR] (pool-14-thread-4) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      2012-01-09 16:07:25,121 ERROR [STDERR] (pool-14-thread-4) at java.lang.Thread.run(Thread.java:662)
      2012-01-09 16:07:26,035 ERROR [STDERR] (pool-14-thread-3) Exception in thread "pool-14-thread-3"
      2012-01-09 16:07:26,035 ERROR [STDERR] (pool-14-thread-3) java.lang.NullPointerException
      2012-01-09 16:07:26,035 ERROR [STDERR] (pool-14-thread-3) at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:191)
      2012-01-09 16:07:26,035 ERROR [STDERR] (pool-14-thread-3) at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
      2012-01-09 16:07:26,035 ERROR [STDERR] (pool-14-thread-3) at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      2012-01-09 16:07:26,035 ERROR [STDERR] (pool-14-thread-3) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      2012-01-09 16:07:26,035 ERROR [STDERR] (pool-14-thread-3) at java.lang.Thread.run(Thread.java:662)
      2012-01-09 16:07:39,933 ERROR [STDERR] (Thread-20) Exception in thread "Thread-20"
      2012-01-09 16:07:39,933 ERROR [STDERR] (Thread-20) java.lang.NullPointerException
      2012-01-09 16:07:39,933 ERROR [STDERR] (Thread-20) at hudson.plugins.audit_trail.AuditTrailPlugin$1.run(AuditTrailPlugin.java:90)

        Issue Links

          Activity

          alexlehm Alex Lehmann added a comment -

          i believe there is an issue for winstone with slf4j already JENKINS-12446

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Kohsuke Kawaguchi
          Path:
          changelog.html
          maven-plugin/pom.xml
          pom.xml
          war/pom.xml
          http://jenkins-ci.org/commit/jenkins/ef1ad6ca29c313fa0b4bc6f5dcd8344046221049
          Log:
          [FIXED JENKINS-12334 JENKINS-12446 JENKINS-12650]

          Bundle slf4j binding to the war.
          See the comment in war/pom.xml for detailed discussion.

          This is fundamentally a "damned if I do, damned if I don't" situation,
          but given that JENKINS-12334 is a fatal error, and the downside of
          bundling the binding jar is "multiple binding" warning, it seems like
          the lesser evil is to bundle it and risk some warnings.

          alexlehm Alex Lehmann added a comment - - edited

          JENKINS-12867: this is the indentical error message, however the fix wasn't out at the time the 2nd issue was written

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Kohsuke Kawaguchi
          Path:
          maven-plugin/pom.xml
          pom.xml
          war/pom.xml
          http://jenkins-ci.org/commit/jenkins/7cc71cd78ea5839bec9a4c881c00751dde9b5b5a
          Log:
          [FIXED JENKINS-12334 JENKINS-12446 JENKINS-12650]

          Bundle slf4j binding to the war.
          See the comment in war/pom.xml for detailed discussion.

          This is fundamentally a "damned if I do, damned if I don't" situation,
          but given that JENKINS-12334 is a fatal error, and the downside of
          bundling the binding jar is "multiple binding" warning, it seems like
          the lesser evil is to bundle it and risk some warnings.

          Cherry-picked-from: ef1ad6ca29c313fa0b4bc6f5dcd8344046221049

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Kohsuke Kawaguchi
          Path:
          pom.xml
          http://jenkins-ci.org/commit/maven-plugin/40034fea378dba1fee10a57493981a937433dfe6
          Log:
          [FIXED JENKINS-12334 JENKINS-12446 JENKINS-12650]

          Bundle slf4j binding to the war.
          See the comment in war/pom.xml for detailed discussion.

          This is fundamentally a "damned if I do, damned if I don't" situation,
          but given that JENKINS-12334 is a fatal error, and the downside of
          bundling the binding jar is "multiple binding" warning, it seems like
          the lesser evil is to bundle it and risk some warnings.

          Originally-Committed-As: ef1ad6ca29c313fa0b4bc6f5dcd8344046221049


            People

            • Assignee:
              kohsuke Kohsuke Kawaguchi
              Reporter:
              tabmow Terry Sposato
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: