Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-12510

Custom xcodebuild arguments values are not persisted

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      If I add a custom xcode config parameter such as SELECTED_LOCALE=en and click save, the custom parameter is not persisted. When I edit the project config again the parameter isnt there.

      My config.xml file has the following entry for the XCode plugin:

      <builders>
      <au.com.rayh.XCodeBuilder>
      <cleanBeforeBuild>true</cleanBeforeBuild>
      <cleanTestReports>false</cleanTestReports>
      <configuration>In-House</configuration>
      <target>NTC</target>
      <sdk></sdk>
      <symRoot></symRoot>
      <configurationBuildDir>${WORKSPACE}/build/In-House-iphoneos</configurationBuildDir>
      <xcodeProjectPath></xcodeProjectPath>
      <xcodeProjectFile></xcodeProjectFile>
      <xcodebuildArguments>SELECTED_LOCALE=${LOCALE}</xcodebuildArguments>
      <xcodeSchema>In-House</xcodeSchema>
      <xcodeWorkspaceFile></xcodeWorkspaceFile>
      <embeddedProfileFile></embeddedProfileFile>
      <cfBundleVersionValue>2.6</cfBundleVersionValue>
      <cfBundleShortVersionStringValue>2.6</cfBundleShortVersionStringValue>
      <buildIpa>true</buildIpa>
      <unlockKeychain>false</unlockKeychain>
      <keychainPath>${HOME}/Library/Keychains/login.keychain</keychainPath>
      <keychainPwd></keychainPwd>
      </au.com.rayh.XCodeBuilder>
      </builders>

        Attachments

          Activity

          Hide
          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Arnaud Héritier
          Path:
          src/main/java/au/com/rayh/XCodeBuilder.java
          http://jenkins-ci.org/commit/xcode-plugin/45f6c393ee14e2c44525c4e792bc96f8eca8ff4d
          Log:
          JENKINS-12510 : Custom xcodebuild arguments values are not persisted

          Show
          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Arnaud Héritier Path: src/main/java/au/com/rayh/XCodeBuilder.java http://jenkins-ci.org/commit/xcode-plugin/45f6c393ee14e2c44525c4e792bc96f8eca8ff4d Log: JENKINS-12510 : Custom xcodebuild arguments values are not persisted
          Hide
          aheritier Arnaud Héritier added a comment -

          A version 1.3.1 will be available in the update center.
          Sorry for the long delay to fix a stupid bug like this.
          Take care that there is another bug on this field (JENKINS-12800) that doesn't allow it to use spaces in parameter values even if you escape it. I don't have the time to investigate and find a fix for now.

          Show
          aheritier Arnaud Héritier added a comment - A version 1.3.1 will be available in the update center. Sorry for the long delay to fix a stupid bug like this. Take care that there is another bug on this field ( JENKINS-12800 ) that doesn't allow it to use spaces in parameter values even if you escape it. I don't have the time to investigate and find a fix for now.
          Hide
          wharpreet wharpreet added a comment -

          Still facing this issue with 1.4.1
          And checked the master branch in github, the changed made for 1.3.1 are still present.

          Show
          wharpreet wharpreet added a comment - Still facing this issue with 1.4.1 And checked the master branch in github, the changed made for 1.3.1 are still present.
          Hide
          lacostej lacostej added a comment -

          I tested locally with a recent jenkins (Jenkins ver. 1.565.1)

          and a new project with xcode builder.

          The field appears in the config when saved.

          <xcodebuildArguments>SELECTED_LOCALE=en</xcodebuildArguments>
          <xcodeSchema></xcodeSchema>
          <xcodeWorkspaceFile></xcodeWorkspaceFile>

          I am using ce1992dc36a1322de363fb16eafa3e5f23af9779 (1.4.3-alpha) version of the plugin and I don't see changes that could affect this.

          I am going to close this issue. If you face the issue again, let us know and we will investigate this further.

          Show
          lacostej lacostej added a comment - I tested locally with a recent jenkins (Jenkins ver. 1.565.1) and a new project with xcode builder. The field appears in the config when saved. <xcodebuildArguments>SELECTED_LOCALE=en</xcodebuildArguments> <xcodeSchema></xcodeSchema> <xcodeWorkspaceFile></xcodeWorkspaceFile> I am using ce1992dc36a1322de363fb16eafa3e5f23af9779 (1.4.3-alpha) version of the plugin and I don't see changes that could affect this. I am going to close this issue. If you face the issue again, let us know and we will investigate this further.
          Hide
          lacostej lacostej added a comment -

          Marked as solved again as we cannot reproduce.

          Show
          lacostej lacostej added a comment - Marked as solved again as we cannot reproduce.

            People

            • Assignee:
              lacostej lacostej
              Reporter:
              rking999 Richard King
            • Votes:
              2 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: