Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-12666

Subversion fails first revision check

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: subversion-plugin
    • Labels:
      None
    • Environment:
      SuseEnterprise Linux
      JDK 1.6
    • Similar Issues:

      Description

      After committing a change into a Subversion repository, Jenkins jobs fail on the first Subversion revision check (see log below).
      Restarting the same job without any other Subversion commit, the revision check has no error and the job runs fine.
      After the next commit, the same error occurs.

      The Subversion server (1.6) runns on a different machine. Authentication is activated. Jenkins knows the credentials of the repo.

      I tested Subversion plugin 1.34, 1.35 and 1.37: always the same error.

      Log:

      Started by user Fischer, Lars
      Building on master in workspace
      /data/hudson_home/jobs/test.pt.prototype-parent/workspace
      Updating svn://server/test/prototype/parent
      U         pom.xml
      At revision 8512
      hudson.util.IOException2: revision check failed on
      svn://server/test/prototype/parent
             at hudson.scm.SubversionChangeLogBuilder.buildModule(SubversionChangeLogBuilder.java:170)
             at hudson.scm.SubversionChangeLogBuilder.run(SubversionChangeLogBuilder.java:112)
             at hudson.scm.SubversionSCM.calcChangeLog(SubversionSCM.java:555)
             at hudson.scm.SubversionSCM.checkout(SubversionSCM.java:702)
             at hudson.model.AbstractProject.checkout(AbstractProject.java:1195)
             at hudson.model.AbstractBuild$AbstractRunner.checkout(AbstractBuild.java:576)
             at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:465)
             at hudson.model.Run.run(Run.java:1409)
             at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:481)
             at hudson.model.ResourceController.execute(ResourceController.java:88)
             at hudson.model.Executor.run(Executor.java:238)
      Caused by: org.tmatesoft.svn.core.SVNAuthenticationException: svn:
      Item is not readable
             at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:62)
             at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:51)
             at org.tmatesoft.svn.core.internal.io.svn.SVNReader.handleFailureStatus(SVNReader.java:269)
             at org.tmatesoft.svn.core.internal.io.svn.SVNReader.parse(SVNReader.java:248)
             at org.tmatesoft.svn.core.internal.io.svn.SVNConnection.read(SVNConnection.java:260)
             at org.tmatesoft.svn.core.internal.io.svn.SVNRepositoryImpl.read(SVNRepositoryImpl.java:1280)
             at org.tmatesoft.svn.core.internal.io.svn.SVNRepositoryImpl.logImpl(SVNRepositoryImpl.java:835)
             at org.tmatesoft.svn.core.io.SVNRepository.log(SVNRepository.java:1034)
             at org.tmatesoft.svn.core.wc.SVNLogClient.doLog(SVNLogClient.java:1027)
             at org.tmatesoft.svn.core.wc.SVNLogClient.doLog(SVNLogClient.java:894)
             at org.tmatesoft.svn.core.wc.SVNLogClient.doLog(SVNLogClient.java:826)
             at hudson.scm.SubversionChangeLogBuilder.buildModule(SubversionChangeLogBuilder.java:158)
             ... 10 more
      Caused by: org.tmatesoft.svn.core.SVNErrorMessage: svn: Item is not readable
             at org.tmatesoft.svn.core.SVNErrorMessage.create(SVNErrorMessage.java:200)
             at org.tmatesoft.svn.core.SVNErrorMessage.create(SVNErrorMessage.java:146)
             at org.tmatesoft.svn.core.SVNErrorMessage.create(SVNErrorMessage.java:89)
             at org.tmatesoft.svn.core.internal.io.svn.SVNReader.getErrorMessage(SVNReader.java:283)
             at org.tmatesoft.svn.core.internal.io.svn.SVNReader.handleFailureStatus(SVNReader.java:261)
             ... 19 more
      Retrying after 10 seconds
      

        Attachments

          Issue Links

            Activity

            lfischer lfischer added a comment -

            This seems to be related to my Subversion configuration. I need to prevent anonymous read access.

            Jenkins / Subversion plugin tries to read the Subversion revision details without authentification and the Subversion server rejects this.

            Should Jenkins be forced to use authentification, if there are known credentials?

            sunnyl sunnyl added a comment - - edited

            I'm also running across this problem. v 1.495 WAR file, Subversion 1.44

            Using Jenkins to deploy a specific build by adding a repo@${revision} parameter to the SVN URL, using HEAD is fine, but using any specific revision only works when there is anon read access to the repo, which is not desirable for a private repo.

            greghansen Greg Hansen added a comment -

            I'm running Jenkins 1.555 with SVN plugin 2.2, and get the same thing. New commits cause a failure, re-runs with no further commits succeed. I do have repo@${revision} in my SVN URL, as above. Revision is set to the value HEAD when these fail. Have not tried setting a specific revision.

            greghansen Greg Hansen added a comment -

            I tried going back to SVN plugin 1.5; no joy. I then went back to the Jenkins version that had been running for a while (will have to add revision if I revert again), still got errors. This had been running flawlessly until I tried the upgrade, so I'm wondering if some data structure was changed by the upgrade.

            greghansen Greg Hansen added a comment -

            The prior version was 1.519 with the 1.50 Subversion plugin.

            greghansen Greg Hansen added a comment -

            Not entirely sure, but we think this was resolved by going to one of the projects, where there was a red message asking if we wanted to supply credentials. Did that for one project, and the red message disappeared from all projects. A test run seems to have gotten past that point. This was after reverting to Jenkins 1.519, Subversion plugin 1.54, and removing the Matrix Role Based Access plugin and Active Directory plugin.

            leopinho leo pinho added a comment -

            I have the same issue - jenkins 1.613 - subversion plugin 2.5

            recena Manuel Recena Soto added a comment -

              People

              • Assignee:
                recena Manuel Recena Soto
                Reporter:
                lfischer lfischer
              • Votes:
                6 Vote for this issue
                Watchers:
                10 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: