Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-12675

Add an option to install specific selenium version on the running nodes

    Details

    • Similar Issues:

      Description

      People have been asking over email that it would be nice to be able to use the latest selenium version, so here is the ticket for that.

        Attachments

          Activity

          Hide
          krmahadevan Krishnan Mahadevan added a comment -

          Yes. I vote for this too.
          The plug-in should be able to let me choose a newer version of "Selenium" if available and if nothing is provided it should work with the current embedded version of Selenium.

          Show
          krmahadevan Krishnan Mahadevan added a comment - Yes. I vote for this too. The plug-in should be able to let me choose a newer version of "Selenium" if available and if nothing is provided it should work with the current embedded version of Selenium.
          Hide
          salmira Tetiana Tvardovska added a comment -

          I also vote for this. Actual Selenium 2 version is 2.20 already, but this plugin still uses old 2.15.

          If there were an option to change default used version without plugin rebuild, we could upgrade Selenium core by configuring Jenkins without disturbing plugin developers...

          Show
          salmira Tetiana Tvardovska added a comment - I also vote for this. Actual Selenium 2 version is 2.20 already, but this plugin still uses old 2.15. If there were an option to change default used version without plugin rebuild, we could upgrade Selenium core by configuring Jenkins without disturbing plugin developers...
          Hide
          ssafyanbynd Sam Safyan added a comment -

          This is becoming more and more of an issue as the selenium.jar that the plugin references becomes more and more outdated. Can we please fix it so that it automatically starts pulling the most recent (v 2.33 as of this writing) version of selenium? Thanks

          Show
          ssafyanbynd Sam Safyan added a comment - This is becoming more and more of an issue as the selenium.jar that the plugin references becomes more and more outdated. Can we please fix it so that it automatically starts pulling the most recent (v 2.33 as of this writing) version of selenium? Thanks
          Hide
          darkrift Richard Lavoie added a comment -

          It is unfortunately not that easy because when new versions of selenium gets out, sometimes it comes with new servers binaries (IE driver server) which is hard to decouple from the main plugin. Version 2.4 has been released today and includes 2.41.0 which was just released.

          Show
          darkrift Richard Lavoie added a comment - It is unfortunately not that easy because when new versions of selenium gets out, sometimes it comes with new servers binaries (IE driver server) which is hard to decouple from the main plugin. Version 2.4 has been released today and includes 2.41.0 which was just released.

            People

            • Assignee:
              darkrift Richard Lavoie
              Reporter:
              darkrift Richard Lavoie
            • Votes:
              5 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: