Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-12953

SVN Tag failing even though the Remote Module Location & Tag Base URL values are correct

    Details

    • Type: Bug
    • Status: Open (View Workflow)
    • Priority: Major
    • Resolution: Unresolved
    • Component/s: svn-tag-plugin
    • Labels:
      None
    • Environment:
      Jenkins 1.452 on AIX 6.1.0.1 with Jenkins Subversion Plugin 1.39 and Jenkins Subversion Tagging Plugin 1.16 with IBM JRE 1.6.0
    • Similar Issues:

      Description

      BUILD SUCCESSFUL
      Total time: 11 seconds
      Remote Module Location: https://SVNSERVERHOSTNAME/svn/SVNPROJECTNAME/trunk@1020.
      Tag Base URL: https://SVNSERVERHOSTNAME/svn/SVNPROJECTNAME/tags/TemporaryTag_by_Jenkins.
      There was no old tag at https://SVNSERVERHOSTNAME/svn/SVNPROJECTNAME/tags/TemporaryTag_by_Jenkins.
      Subversion copy failed. svn: File not found: revision 1020, path '/trunk/trunk'
      svn: '/svn/SVNPROJECTNAME/!svn/bc/1020/trunk' path not found: 404 Not Found (https://SVNSERVERHOSTNAME)
      Build step 'Perform Subversion tagging on successful build' marked build as failure
      Finished: SUCCESS

      https://SVNSERVERHOSTNAME/svn/SVNPROJECTNAME/!svn/bc/1020/trunk/ works fine in browser as URL and I can see the contents fine.
      Command line Subversion Tagging works fine with the same Remote Module Location & Tag Base URL values.
      I don't understand where it's picking up '/trunk/trunk'

        Attachments

          Activity

          Hide
          jatintak Jatin Tak added a comment -

          I am facing a similar problem with the plugin.

          Subversion copy failed. svn: File not found: revision 8286, path '/branches/samplePath/branches/samplePath'

          It is appending the path to itself. Any idea why this is happening and/or a workaround to this issue?

          Show
          jatintak Jatin Tak added a comment - I am facing a similar problem with the plugin. Subversion copy failed. svn: File not found: revision 8286, path '/branches/samplePath/branches/samplePath' It is appending the path to itself. Any idea why this is happening and/or a workaround to this issue?

            People

            • Assignee:
              k2nakamura k2nakamura
              Reporter:
              skurra Suresh Kurra
            • Votes:
              2 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated: