Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-12970

NPE in disk-usage during jenkins startup

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: disk-usage-plugin
    • Labels:
      None
    • Environment:
      Jenkins ver. 1.452

      java version "1.7.0"
      Java(TM) SE Runtime Environment (build 1.7.0-b147)
      Java HotSpot(TM) 64-Bit Server VM (build 21.0-b17, mixed mode)
    • Similar Issues:

      Description

      After updating disk-usage plugin to version 0.15 I can't start jenkins anymore. During statup process following error appears:

      org.jvnet.hudson.reactor.ReactorException: java.lang.Error: java.lang.reflect.InvocationTargetException
      	at org.jvnet.hudson.reactor.Reactor.execute(Reactor.java:246)
      	at jenkins.InitReactorRunner.run(InitReactorRunner.java:43)
      	at jenkins.model.Jenkins.executeReactor(Jenkins.java:824)
      	at jenkins.model.Jenkins.<init>(Jenkins.java:736)
      	at hudson.model.Hudson.<init>(Hudson.java:81)
      	at hudson.model.Hudson.<init>(Hudson.java:77)
      	at hudson.WebAppMain$2.run(WebAppMain.java:217)
      Caused by: java.lang.Error: java.lang.reflect.InvocationTargetException
      	at hudson.init.InitializerFinder.invoke(InitializerFinder.java:124)
      	at hudson.init.InitializerFinder$TaskImpl.run(InitializerFinder.java:184)
      	at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
      	at jenkins.model.Jenkins$5.runTask(Jenkins.java:813)
      	at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
      	at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
      	at java.lang.Thread.run(Thread.java:722)
      Caused by: java.lang.reflect.InvocationTargetException
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.lang.reflect.Method.invoke(Method.java:601)
      	at hudson.init.InitializerFinder.invoke(InitializerFinder.java:120)
      	... 8 more
      Caused by: java.lang.NullPointerException
      	at hudson.plugins.disk_usage.DiskUsageProperty$DiskUsageDescriptor.access$000(DiskUsageProperty.java:46)
      	at hudson.plugins.disk_usage.DiskUsageProperty.transitionAuth(DiskUsageProperty.java:36)
      	... 13 more
      

      Previous version of disk-usage (0.14) plugin works ok.

        Attachments

          Activity

          guilhem Guilhem Lettron added a comment -

          Same things here :
          Installation of "Dashboard view plugin (2.2)" resolved the problem.

          krumboeck Bernd Krumböck added a comment -

          I confirm:
          Dashboard view plugin 2.2 resolves the problem.

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Vojtech Juranek
          Path:
          src/main/java/hudson/plugins/disk_usage/DiskUsageProperty.java
          http://jenkins-ci.org/commit/disk-usage-plugin/a1a0230c1de216b5357e6da341564173a1faceb3
          Log:
          [FIXED JENKINS-12970] Fixed possible NPE when DI fails to load plugins, not to block whole Jenkins startup.

          vjuranek vjuranek added a comment -

          Please note, that this is just a fix which allows Jenkins to continue with startup. The root issue is in Jenkins core.

          dogfood dogfood added a comment -

          Integrated in plugins_disk-usage #43
          [FIXED JENKINS-12970] Fixed possible NPE when DI fails to load plugins, not to block whole Jenkins startup. (Revision a1a0230c1de216b5357e6da341564173a1faceb3)

          Result = SUCCESS
          Vojtech Juranek :
          Files :

          • src/main/java/hudson/plugins/disk_usage/DiskUsageProperty.java

            People

            • Assignee:
              vjuranek vjuranek
              Reporter:
              maciej_oledzki Maciej Olędzki
            • Votes:
              6 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: